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TrueType Fonts Installed Incorrectly

Summary

If you use the Setup program in Microsoft Word for Windows version 2.0 to install Microsoft Equation 
Editor version 1.0 in Windows 3.1, the Setup program does not install these two Equation Editor 
TrueType fonts correctly: 

MT Extra
Fences

These fonts appear in the Installed Fonts list in the Fonts dialog box of the Control Panel, but do not 
appear in the Sample box when selected. To use these fonts, you must reinstall them using one of 
the procedures listed below.

Microsoft has confirmed this to be a problem in Word for Windows version 2.0. This problem was 
corrected in version 2.0a.

Note: This problem does not occur when you use the Setup program in Word for Windows version 
2.0a or with any other TrueType fonts.

More Information

The Microsoft Equation Editor, which ships with Microsoft Word for Windows versions 2.0 and 2.0a, 
comes with two TrueType fonts, MT Extra and Fences. These TrueType fonts are designed for use 
with Windows 3.1. To use these fonts, the Equation Editor must be installed after you install Windows
3.1. Windows 3.0 does not use TrueType fonts, so these fonts are not installed when you run the 
Word for Windows Setup program in Windows 3.0.

If you use the Setup program in Word for Windows version 2.0 to reinstall the Equation Editor after 
installing Windows 3.1 (in order to add the TrueType version of the Equation Editor fonts), MT Extra 
and Fences are installed incorrectly. Although these fonts appear in the Installed Fonts box in the 
Fonts dialog box of the Control Panel, the Sample box is empty when you select MT Extra of Fences.
These two fonts also are unavailable in Word for Windows and Microsoft Windows Write.

To correctly install the MT Extra and Fences TrueType fonts, use one of these two methods:

Method 1

1. In the Control Panel, choose the Fonts icon. 
2. In the Fonts dialog box, select MT Extra, and choose the Remove button. 
3. In the Remove Font box, clear the Delete Font File From Disk option, and choose the Yes 

button. 
4. Repeat this process for the Fences font. 
5. Choose the Add button. In the Directories box, select the Windows \SYSTEM subdirectory, and 

choose the OK button. 
6. In the List of Fonts box, select MT Extra Plain (TrueType) and Fences Plain (TrueType), then 

choose the OK button. Choose the Close button to exit the Fonts dialog box. 
7. Exit and restart Windows.

Note: The newly added font names are Fences Plain and MT Extra Plain. The Equation Editor works 
correctly with these fonts.

Method 2



1. In the Control Panel, choose the Fonts icon. 
2. In the Fonts dialog box, select MT Extra, and choose the Remove button. 
3. In the Remove Font box, check the Delete Font File From Disk option, and choose the Yes 

button. 
4. Repeat this process for the Fences font. Using the Word for Windows version 2.0a Setup 

program, reinstall the Equation Editor. 
5. Exit and restart Windows.

To obtain new or updated Microsoft products, call Microsoft End User Sales at (800) 426-9400. If you 
are outside the United States, contact the Microsoft subsidiary for your area. To locate your 
subsidiary, call Microsoft International Customer Service at (206) 936-8661.

Reference(s)

"Microsoft Word for Windows Getting Started," version 2.0, pages 8-11

Additional Search Words 
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Troubleshooting Word Setup Failure

Summary

If the Microsoft Word for Windows Setup program fails to install the Word for Windows files onto your 
system and all the usual troubleshooting techniques fail, you may be able to install Word for Windows
by copying Disk 1 to your hard disk and decompressing the SETUP.EX$ file from the Setup disk to 
replace the existing SETUP.EXE file. 

More Information

If you receive the message "Insufficient memory or disk space" during setup or if you cannot install 
the program for another reason, attempt installation using these steps:

1. Copy the files from Disk 1 to the hard disk.

2. Quit Windows.

3. From the directory on the hard disk containing the Setup (Disk 1) files, type the following at the 
MS-DOS prompt:

DECOMP SETUP.EX$ SETUP.EXE
This decompresses the SETUP.EX$ file and replaces the existing SETUP.EXE file.

This message is displayed:

Warning: SETUP.EXE already exists. Do you want to append to it?

4. Choose the No button and continue with setup. This message is then displayed:

Should I try to overwrite it?

5. Choose the Yes button in response to this message.

6. Restart Windows and run the new SETUP.EXE file from its directory on the hard disk.

Reference(s)

"Microsoft Word for Windows Getting Started," version 2.0, page 11

Additional Search Words 

tshoot cannot 



Setup Deletes Older WINWORD.EXE Before Checking Disk Space

Summary

If you install version 2.0 of Word for Windows over a previous version, the older WINWORD.EXE file 
is deleted before Setup determines if there is sufficient disk space for the desired installation. If your 
computer does not have sufficient disk space and Setup is canceled, the previous installation no 
longer functions because WINWORD.EXE is missing.

This problem was corrected in Word for Windows version 2.0a. If there is insufficient disk space or 
Setup is aborted, Word for Windows does remove the existing graphics converters (.FLT files) but 
does not remove the WINWORD.EXE file.

Steps to Reproduce Problem

Note: The steps below assume that Word for Windows version 1.x is installed on a disk partition with 
insufficient free space for the desired version 2.0 Word for Windows Setup options.

1. Run the version 2.0 Word for Windows Setup program. Choose the directory where version 1.x 
is installed, and choose to overwrite the previous version. Select the Custom Installation option, 
then select enough options to exceed the available disk space.

2. When Setup reports insufficient disk space for the requested custom installation, choose the 
Cancel button to end Setup.

3. Open File Manager, and view the WINWORD program directory.

Note that the WINWORD.EXE file is missing.

Below is a list of files in a typical installation of Word for Windows version 1.1a before Setup is 
canceled for version 2.0 of Word for Windows:

.          <DIR>

..        <DIR>
WINWORD.CBT <DIR>
ADIMPORT.FLT 6K
CGMMPORT.FLT 46K
CONV-DCA.DLL 152K
CONV-MCW.DLL 114K
CONV-MM.DLL 96K
CONV-TX8.DLL 174K
CONV-TXT.DLL 172K
CONV-WP.DLL 86K
CONV-WP5.DLL 124K
CONV-WRD.DLL 128K
CONV-WRI.DLL 56K
CONV-WS.DLL 104K
CONV-WWP.DLL 60K
CONVERT.GLY 3K
DRAW.FLT 12K
EPSIMP.FLT 70K
HPGLIMP.FLT 34K
HYPH.DAT 24K
IMAMPORT.FLT 42K
ISV.DOC 4K
KEYCAPS.DOC 11K



LEX-AM.DAT 185K
LEX-AM.DLL 44K
LOTUSPIC.FLT 5K
MACROS.DOC 33K
NORMAL.DOT  3K
NORMAL.OLD  5K
PCW-RTF.DAT 1K
PCX.TXT 5K
PREV.FON 10K
README.DOC 37K
README.TXT 22K
STDUSER.DIC 1K
SYMBOLA.FON 38K
SYN-AM.DAT 296K
SYN-AM.DLL 20K
TECHREF.DOC 165K
TIFFIMP.FLT 58K
VIDMPORT.FLT 69K
WHELP.EXE 70K
WINWORD.EXE 879K
WINWORD.HLP 424K
WINWORD.INI 19K
WMF.FLT 2K
4,579,577 bytes in 47 file(s)

This is a list of files that remain after you cancel version 2.0 Word for Windows Setup on the above 
directory:

.          <DIR>

..        <DIR>
WINWORD.CBT <DIR>
CONV-MM.DLL 96K
CONV-WRI.DLL 56K
CONV-WWP.DLL 60K
CONVERT.GLY 3K
IMAMPORT.FLT 42K
ISV.DOC 4K
KEYCAPS.DOC 11K
MACROS.DOC 33K
NORMAL.DOT  3K
NORMAL.OLD  5K
PCW-RTF.DAT 1K
PCX.TXT 5K
PREV.FON 10K
README.DOC 37K
README.TXT 22K
STDUSER.DIC 1K
SYMBOLA.FON 38K
TECHREF.DOC 165K
TIFFIMP.FLT 58K
VIDMPORT.FLT 69K
WINWORD.INI 19K
1,346,378 bytes in 24 file(s)

Reference(s)



"Microsoft Word for Windows Getting Started," version 2.0, pages 7-11

Additional Search Words 

gone won't run prior 



General Troubleshooting Tips

Summary

This article contains troubleshooting information specific to Microsoft Word for Windows. Use this 
along with normal software troubleshooting techniques if you encounter Word for Windows problems.

Rename NORMAL.DOT

Word for Windows uses the NORMAL.DOT template file to establish the default styles, macros, key 
assignments, menus items, toolbar choices, glossaries, and boilerplate text. Because NORMAL.DOT
is a global file, it can cause problems in every Word for Windows session and every new file if it is 
corrupted. If you exit Word for Windows, rename NORMAL. DOT, and restart the program, all default 
Word settings are restored.

Note: NORMAL.DOT contains many useful settings that must be re-created if the file is corrupted. Be
sure to change its filename back to NORMAL.DOT if you discover that NORMAL.DOT is not the 
source of the problem.

Rename WINWORD.INI

Word for Windows uses the WINWORD.INI file to store the most recent settings, such as window 
size and user information. As with NORMAL.DOT, corruption in WINWORD.INI can affect many 
aspects of your Word for Windows session. Word rebuilds this file whenever you exit the program; 
therefore, you do not need to rename the file back to WINWORD.INI. If this file is deleted, Word 
opens with the original default settings.

Switch to a Different Printer Driver

Unlike many Windows-based applications, Word for Windows uses the printer driver for numerous 
tasks because its primary concern is the printed appearance of the document. When you are printing 
or viewing a document, problems with printer drivers can cause Word for Windows to display the 
document incorrectly on the screen, generate incorrect printed output, or even hang Word. By using 
a different printer driver, you can determine if the problem is related to the printer driver.

If your Word for Windows documents print as garbled output, you may need to disable the Fast 
Printing Direct To Port setting in the Windows Control Panel. To do this, choose the Printers icon in 
Control Panel and choose the Connect button. In the Connect dialog box, clear the Fast Printing 
Direct To Port check box and choose the OK button. When this option is disabled, Windows 3.1 prints
using standard MS-DOS interrupts instead of printing directly to the port. For more information on the
Fast Printing Direct To Port setting, see pages 30, 32, and 426-429 of the "Microsoft Windows 
Resource Kit" for operating system version 3.1.

Switch to a Different Printer Driver in Windows Write

Microsoft Windows Write and Word for Windows use printer drivers similarly. Both applications get 
most of their information from the printer driver; therefore, Write and Word often produce the same 
results when the printer driver is causing problems.

Note: Word exploits more features of the printer driver than Write, so experimenting with Write is not 
an exhaustive test for all printer driver problems in Word.

Check the File Size and Dates of the OLE DLL Files

Word for Windows (and other OLE applications) use DLL files during object linking and embedding. 
Old, outdated versions of DLL files should not be used with Word for Windows. Reinstall these files if 



you suspect they are out of date or corrupt. The DLL files that ship with Word for Windows are for use
with Microsoft Windows operating system version 3.1.

Check the Following Sections in WIN.INI

[Microsoft Word 2.0] - versions 2.0, 2.0a, and 2.0a-CD only
[MS Word Text Converters] versions 2.0, 2.0a, and 2.0a-CD only
[MS Word Editable Sections] - versions 2.0, 2.0a, and 2.0a-CD only
[Microsoft Word] - versions 1.0, 1.1, and 1.1a only
[WWFilters] - versions 1.0, 1.1, and 1.1a only

For more information on the settings in these WIN.INI sections:

Refer to pages 396-397 in the "Microsoft Word for Windows User's Reference" for version 1.x.
Refer to Appendix B in the "Microsoft Word for Windows User's Guide" for version 2.0.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, pages 803-810
"Microsoft Word for Windows User's Reference," version 1.x, pages 396-397
"Microsoft Windows Resource Kit," version 3.1, pages 30, 32, 426-429

Additional Search Words

tshoot garbage 



How Word Uses the REG.DAT File in Windows 3.1

Summary

Microsoft Word for Windows uses information from the Registration Database file (REG.DAT) for its 
object-linking-and-embedding (OLE) activities. In Microsoft Windows operating system version 3.1, 
REG.DAT provides the information used by File Manager and Print Manager to support drag-and-
drop functionality. When you first install Windows 3.1, the REG.DAT file contains information about all
the OLE applications included with Windows. You should never move or delete REG.DAT; doing so 
can result in loss of functionality in File Manager, Program Manager, and applications that support 
OLE.

More Information

The Word for Windows Setup program updates REG.DAT by adding information about the program 
and the OLE server applications (Microsoft Graph, Microsoft Draw, Microsoft WordArt, and Microsoft 
Equation Editor) that ship with Word for Windows. During network installation, Setup updates 
REG.DAT for the server or workstation, depending on where Windows is installed. If your WINDOWS
directory is flagged as read only, Word for Windows Setup cannot update the REG.DAT file, nor can it
copy the OLE server application files to the WINDOWS subdirectories. If this occurs, Word for 
Windows Setup generates an error message.

If you cannot launch the OLE server applications from Word for Windows, you may need to update 
REG.DAT. To do this, use the Registration Info Editor (REGEDIT.EXE) program, which ships with 
Windows 3.1. You can also reconstruct the REG.DAT file by running Word for Windows Setup to 
reinstall the program.

Important Note: If you move any OLE server applications, you must update the REG.DAT file so that
Word for Windows can locate them.

To update REG.DAT using REGEDIT.EXE, use the steps below.

Note: Be sure to make a backup copy of the REG.DAT file before you use these instructions.

1. From the Program Manager File menu, choose Run.

2. In the Command Line box, type REGEDIT then choose the OK button.

3. Under Registered File Types, select the file type you want to update (for example, Word 
Document).

4. From the Edit menu, choose Modify File Type.

5. Type the correct location in the Command box, or choose the Browse button to locate the 
program file. (For example, for Word Document, locate the WINWORD.EXE file.) Choose the OK
button.

6. From the File menu, choose Exit. Your changes are written to the REG.DAT file at this time.

Note: CheckFree software uses a non-Windows-related file called REG.DAT. Be sure to select the 
correct REG.DAT file if you have both Windows and CheckFree. CheckFree is manufactured by 
CheckFree Corporation, a vendor independent of Microsoft; we make no warranty, implied or 
otherwise, regarding this product's performance or reliability.

README.DOC



Page 3 of the Word for Windows README.DOC file contains information about problems you can 
experience if another application uses the OLE servers and modifies the REG.DAT file.

Reference(s)

Microsoft Word for Windows, version 2.0, README.DOC, page 3
"Microsoft Word for Windows User's Guide," version 2.0, pages 803, 810
"Microsoft Windows Resource Kit," version 3.1, pages 359, 361-363, 454

Additional Search Words 

msapps applet msdraw m



Status Bar Display of At and Ln Information in Word

Summary

The status bar At and Ln information does not display in draft view in Microsoft Word for Windows. If 
you are working in another view and the At and Ln information does not display, you may need to 
adjust the options described below. 

Word for Windows Versions 2.0 and later

To display the status bar At and Ln information, you must select the Background Pagination option: 
choose Options from the Tools menu, select the General category, and select the Background 
Pagination check box. The At and Ln information now is displayed while in the page layout and 
outline views.

If you are working in normal view, you must also select the Line Breaks and Fonts as Printed option: 
choose Options from the Tools menu, select the View category, and mark the appropriate check box. 
Line Breaks and Fonts as Printed is an available option in normal view. The option is unavailable in 
the outline, page layout, and draft views.

Word for Windows Versions 1.x

To display the At and Ln information in page view, you must select the Background Pagination option 
by choosing Customize from the Utilities menu and selecting the appropriate check box. If you use 
normal (galley) or outline view, choose Preferences from the View menu, and select the Display as 
Printed option to see this information. 

More Information

If a printer driver is not selected in the Printer Setup dialog box, the At and Ln information does not 
display.

The status bar At and Ln number information is based on the current insertion point position. "At" 
refers to the insertion point position from the top of page. "Ln" refers to the current line number from 
the top margin.



Changing the Default Directory of Word

Summary

The default directory that Microsoft Word for Windows opens files from and saves files to is the 
directory from which Word for Windows was started. 

There is no WIN.INI setting for specifying the default directory where Word for Windows 1.x should 
look for .DOC files. Use the Macro Method listed below for Word for Windows versions 1.0, 1.1, 1.1a.

More Information

Note: The following routines assume that Word for Windows appears in the PATH statement in the 
AUTOEXEC.BAT file.

Word for Windows Versions 2.0 and later

You can change a document path variable in the WIN.INI file to specify a specific path for .DOC files. 
This path is set to the Word for Windows directory during setup. In the [Microsoft Word 2.0] section of
the WIN.INI, the entry reads as follows:

[Microsoft Word 2.0]
DOC-path=c:\directoryname

To change the path, choose Options from the Tools menu, and select the WIN.INI icon. Select DOC-
path=C\WINWORD from the Startup Options box, and enter a new path in the Setting box.

Full Windows

If you are using a full version of Windows, use the following batch file from the command prompt to 
start Word for Windows in a specific directory (MYDOCS, in this example):

cd c:\winword\mydocs
win winword

Macro Method

The following method involves defining an auto macro that changes the current directory every time 
you start Word for Windows:

1. From the Macro menu, choose Record.

2. Type "AutoExec" (without the quotation marks) as the macro name.

3. From the File menu, choose Open.

4. Type C:\WINWORD\MYDOCS\*.DOC (where MYDOCS is the name of the directory you want 
the current directory to be) in the filename entry field and choose the OK button.

5. Select the Cancel button in the Open dialog box.

6.  From the Macro menu, choose Stop Recorder.

7. When you exit Word, Word prompts you to "Save global glossary and command changes?" 
Choose the Yes button.



Icon Properties Method

This procedure works only if you are using Microsoft Windows version 3.0:

1. In the Program Manager, select the Word for Windows icon.

2. From the File menu, choose Properties.

3. In the Command Line box, type the full path to the directory you want to be the default, and to 
that path, append WINWORD.EXE. For example, if you want C:\DATADOC to be your default 
directory, type c:\datadoc\winword.exe and choose the OK button.

4. When the error message "The specified path is invalid" appears, choose the OK button.

5. From the File menu, choose Properties.

6. Choose the Change Icon button.

7. Type the real path to the Word for Windows executable file (WINWORD.EXE), and choose the 
OK button twice.

8. When the error message "The specified path is invalid" appears, choose the OK button.

After you perform this procedure, when you load Word for Windows and choose Open from the File 
menu, the C:\DATADOC directory is accessed. Also, all files are saved to this directory unless you 
specify a different directory.

Run-Time Windows

If you are using run-time Windows, you can create the following batch file to start Word in a specific 
directory (MYDOCS, in this example):

cd c:\winword\mydocs
winword

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, page 805

Additional Search Words 

personal startup 



Troubleshooting Problems Reading Setup Disks

Summary

If you attempt to run the Setup program for Microsoft Word for Windows and receive a disk read error
for the floppy disk drive, there may be a problem with the disk. It is also possible that the disk drive 
you are using for Setup does not closely match the alignment of the machine that produced the disk. 
Disk read errors are almost always caused by such problems, rather than by problems related to 
memory configuration, usage, or other environmental factors.

More Information

You can perform a simple test to determine whether or not the drive is capable of reading the disk. At 
the MS-DOS prompt, change the drive letter to the drive you are using for Setup, then follow the 
steps below with each disk:

1. At the MS-DOS prompt, type the following, and press ENTER:

CHKDSK 
If CHKDSK runs successfully but finds errors, the disk is probably corrupt. CHKDSK /F does not 
fix any of the disk problems it finds. 

If CHKDSK runs successfully and does not find errors, do not consider this a definitive check. 
CHKDSK does not read the entire disk, it verifies only that there are valid entries in the FAT (File 
Allocation Table) and directories for all the files on the disk. Perform the following test as well:

2. At the MS-DOS prompt, type the following, and press ENTER:

DIR *.  
This determines if any subdirectories exist on the disk.

3. At the MS-DOS prompt, type the following, and press ENTER:

COPY *.* NUL 
Do this for the root directory and any subdirectories found in step 2. This command opens, 
reads, and closes each file in the current directory. This test verifies that each file can actually be
read from the disk.

Using the MS-DOS NUL device as the target for the copy is convenient because no target file is 
created. The output of the command is discarded. If you use NULL as the target file name by 
mistake, the command tries to create a file on the disk; this usually results in an error due to lack
of disk space.

Note: The MS-DOS XCOPY command cannot be used with NUL as the target.

4. You can perform a more rigorous version of the step 3 test by typing the following, and pressing 
ENTER: 

XCOPY *.* /s /v <x>:\<dirname> 
where "x" is a hard disk drive and "dirname" a directory on that drive. The /s switch copies any 
subdirectories on the disk, eliminating the need to run the command multiple times for some 
disks. The /v switch verifies that the source file and the copied file are identical.



If this test is done and succeeds, run Setup from this directory on the hard disk. Specify a 
different directory name when Setup asks for the drive and path to install to. This method 
requires between 14MB and 24MB of available disk space. Approximately 9MB may be 
recovered after the installation by deleting the files in the original directory.

Note: The XCOPY command is not available in versions of MS-DOS or PC-DOS earlier than 
3.3.

If you encounter any read errors in the above tests or if CHKDSK reports drastic errors, perform the 
same tests on another computer. If several other computers are available, it may be advantageous to
try more than one.

If you find a computer that can successfully read the disks, the following workaround will most likely 
allow you to install the software on the original computer. If no available computer can read the disks, it 
is they likely are damaged. If this is the case, you should obtain another original disk set.

Workaround

1. On the original computer, use the MS-DOS FORMAT command to format the same number of 
disks as there are in the disk set for the software you are installing. (Although the step 2 can 
succeed with unformatted disks, you have the best chance of success by formatting the disks on
the original computer.)

2. On the computer that can read the Setup disks, use the MS-DOS DISKCOPY command to copy 
each original disk to one of the formatted disks. The usage for DISKCOPY varies depending on 
the floppy disk drive configuration on this computer; refer to your MS-DOS documentation for the
correct syntax.

Note: It is possible that this computer may unsuccessfully try to read the disks formatted on the 
original computer. If you cannot successfully complete the disk set, try another computer. The 
object is to find a computer that can read both the original Setup disk and the disks formatted on 
the target computer.

3. Take the newly-created disk set back to the original computer, and try to run Setup again. 

Reference(s)

For further information on the MS-DOS commands discussed above, refer to your MS-DOS manual.

"Microsoft Word for Windows Getting Started," version 2.0, pages 7-11
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How the FILES= Configuration Command Affects Word

Summary

In the CONFIG.SYS file, the FILES= configuration command sets the number of file handles 
available to an MS-DOS program, as in the following example:

FILES=30

Microsoft Word for Windows is not directly affected by this setting. Word contains internal program 
code that instructs Microsoft Windows to open 54 file handles for Word's use.

More Information

Although Word for Windows is not directly affected by the number in the FILES= setting, Microsoft 
Windows version 3.0 is an MS-DOS program and may be limited in the number of fonts that it can 
load if the FILES number is too small. If there are insufficient file handles, Windows may display a 
font name but be unable to access its description information. Symptoms of insufficient file handles 
include a change in the display font used by the Program Manager or the failure of fonts to appear in 
Word for Windows. Increasing the FILES= number in the CONFIG.SYS file normally corrects these 
problems.

The "Microsoft MS-DOS version 5.0 User's Guide and Reference" suggests FILES=30 to run 
Windows.

Symantec Corporation suggests FILES=45 to run with Norton Desktop.

Adobe Corporation suggest FILES= should be set between 40 and 60 to run with Adobe Type 
Manager (ATM).

Note: These problems cannot be reproduced in Windows 3.1.

Reference(s)

"Microsoft Quick Reference: MS-DOS, Fifth Edition," pages 101-102, 110
"Microsoft MS-DOS User's Guide and Reference," version 5.0, pages 250, 252, 493



File Changes Between Word Versions 2.0 and 2.0a

Summary

This article includes lists of the file changes between version 2.0 and version 2.0a of Microsoft Word 
for Windows. Word for Windows 2.0a is a maintenance release that contains some additional files 
that 2.0 did not contain. Also, some files common to both versions were changed for 2.0a, and 2.0a 
does not contain all the files that version 2.0 contains.

When you install Word for Windows 2.0a over version 2.0, you can create a custom batch file to 
install the new and changed files rather than run the entire setup again. No REG.DAT or WIN.INI 
changes are necessary if you are simply replacing already existing files.

More Information

The following files are included in version 2.0a but not in version 2.0:

\clipart\monitor.wmf
msetup.inf
\msgraph\msgraph.hlp
pss.doc
\clipart\wm&bcas2.wmf
\clipart\wm&book.wmf

The following files changed between version 2.0 and version 2.0a:

article2.dot
convinfo.doc
datafile.dot
dissert2.dot
\equation\eqnedit.exe
\msgraph\graph.exe
hppcl5a.drv
letblock.dot
letmdsem.dot
letmodbk.dot
letpersn.dot
lotus123.cnv
maillabl.dot
memo2.dot
multimat.cnv (on supplemental converters disk)
newmacro.doc
overhead.dot
press.dot
readme.doc
repland.dot
repside.dot
repstand.dot
setup.exe
spell.dll
term2.dot
winword.exe
winword.hlp
wordwin1.cnv
wperf5.cnv
wrkswin.cnv (on supplemental converters disk)



wword20.inf
xlbiff.cnv

These files are included in version 2.0 but not in version 2.0a:

\clipart\5ppuzzle.wmf
\clipart\ambulanc.wmf
\msgraph\graph.hlp (now msgraph.hlp)
\clipart\multarw2.wmf
\clipart\multarw4.wmf
\clipart\nurse.wmf
\clipart\woman.wmf
wpft4.cnv (moved to supplemental drivers disk)

Additional Search Words 

contents differences



Default Values in REG.DAT

Summary

Here are the default REG.DAT settings that version 2.0 of Word for Windows establishes during 
Setup when running in Windows 3.1: 

.DOC = WordDocument
WordDocument = Word Document
shell
print
ddeexec = [FileOpen("%1")][FilePrint()][DocClose(2)]
ifexec=[FileOpen("%1")][FilePrint()][FileExit(2)]
command=C:\WINWORD\winword.exe
open
ddeexec=[FileOpen("%1")]
command=c:\WINWORD\winword.exe
protocol
StdFileEditing
verb
0=Edit
server=C:\WINWORD\winword.exe
PackageObjects

More Information

The above options are listed as they are displayed by the Windows version 3.1 Registration Info 
Editor (REGEDIT.EXE) while in advanced mode. To start the Registration Info Editor in advanced 
mode, follow these steps:

1. Activate the Windows Program Manager. From the File menu, choose Run.

2. In the Command Line box, type "regedit /v" (without the quotation marks). Choose the OK 
button.

The above settings are established during Word for Windows Setup. These settings are not entirely 
rebuilt from the [Embedding] section of the Windows WIN.INI file; therefore, if you delete the 
REG.DAT file, you must reconstruct these settings manually or by reinstalling Word for Windows.

For additional information about application integration in the REG.DAT file, access the Help menu in 
the Registration Info Editor. The Help information for this application is contained in the REG.HLP file 
located in the Windows directory. 

Additional Search Words 

ole object linking embedding rebuild 



Using MSETUP.INF for a Manual Setup

Summary

MSETUP.INF is a batch file you can use to perform a manual, minimal installation of Microsoft Word 
for Windows version 2.0a. This setup utility copies DECOMP.EXE to your hard disk and then 
decompresses all the necessary Word for Windows files to their appropriate directories. It also 
creates a text file named PSS.TXT and copies this file into the Word for Windows program directory. 
This file contains settings you must add to your WIN.INI file.

Note: This batch file is for use with Microsoft Windows version 3.0 only. MSETUP.INF is not shipped 
with version 2.0b of Word for Windows. 

More Information

A manual setup of Word for Windows may be necessary if the Setup program fails to install the 
program completely.

Use these steps to perform a manual setup using MSETUP.INF: 

    1.Exit Windows. From the MS-DOS prompt, type "C:" (without the quotation marks), and press 
ENTER.

    2.Type "CD\" and press ENTER.

    3.Place the Word for Windows 2.0a Setup disk (Disk 1) in the floppy disk drive.

    4.Type 

COPY A:\MSETUP.INF C:\MSETUP.BAT
and press ENTER. This step copies the MSETUP.INF file to the root directory of the hard disk 
and changes its name to MSETUP.BAT so that you can use it as an executable batch file.

    5.Type 

MSETUP C:\WINWORD C:\WINDOWS A: 
and press ENTER. In this example, C:\WINWORD is the Word for Windows program directory, 
and C:\WINDOWS is the Windows program directory. The floppy disk drive where the Word for 
Windows disks are located is A.

    6.Restart Windows.

    7.Choose the Notepad icon in the Accessories group to start the Windows Notepad text editor.

    8.In Windows Notepad, open the PSS.TXT file, which is located in the Word for Windows program 
directory.

    9.Select the entire file. From the Edit menu, choose Copy.

10. Open the WIN.INI file, which is located in the Windows program directory.

11. Search for the [Embedding] and [Microsoft Word 2.0] sections in the WIN.INI file. If these sections
already exist, delete them. If they do not exist, go directly to step 12.



12. Press CTRL+END to position the insertion point at the end of the WIN.INI file. From the Edit 
menu, choose Paste to insert the contents of the PSS.TXT (copied in step 9 above) into WIN.INI.

13. Save the WIN.INI file and exit Notepad. Exit and restart Windows so the WIN.INI changes take 
effect.

Note: You must manually set up the icon to start Word for Windows in Program Manager.

More Information About MSETUP.INF

You must provide three parameters so that the MSETUP.BAT batch file executes correctly. This 
syntax is as follows:

MSETUP <WinWord program directory> <Windows program directory> <floppy disk
drive>

The first parameter is the full path to the Word for Windows directory (in this example, C:\
WINWORD). The second parameter is the full path to your Windows directory (in this example, C:\
WINDOWS). The last parameter is the drive letter of the floppy disk drive where you want to place 
the Word for Windows disks. For example, if the drive letter is A, the syntax is as follows:

MSETUP C:\WINWORD C:\WINDOWS A:
Change to the root directory or to the directory that contains MSETUP.BAT before you type the above
command. The batch program prompts you to insert the Word for Windows disks in sequential order. 
If you insert the wrong disk, MSETUP again prompts you to insert the proper disk.

When MSETUP is finished decompressing files to their proper directories, it creates and copies 
PSS.TXT into the designated Word for Windows directory. This file contains the Word for Windows 
settings you must enter in the WIN.INI file. Use a text editor to open this file, and copy its contents 
into your WIN.INI file (as described in steps 7-13 above).

Additional Search Words

tshoot



MSETUP.INF Does Not Decompress OLECLI.DLL and OLESVR.DLL

Summary

With Microsoft Word for Windows versions 2.0a and 2.0a-CD, if you use the 5.25-inch, 1.2 MB disks 
to perform a manual setup, MSETUP.INF does not copy OLESVR.DLL and OLECLI.DLL to the hard 
disk. You must manually decompress these files from the original disks and place them in the 
Microsoft Windows SYSTEM subdirectory.

Note: Be sure to run MSETUP.INF as a batch file (MSETUP.BAT) from the hard disk. This batch file 
is for use with Microsoft Windows version 3.0 only.

Note: MSETUP.INF is not included with version 2.0b of Word for Windows.

More Information

The first time you launch Word for Windows after running MSETUP.BAT, you receive two error 
messages:

Change Disk. Cannot find OLECLI.DLL. Please insert in drive A:

Change Disk. Cannot find OLESVR.DLL. Please insert in drive A:

Copy DECOMP.EXE from Disk 1 to the Word for Windows program directory (for example, COPY 
A:DECOMP.EXE C:\WINWORD). The OLESVR.DL$ file is found in the DLL directory on Disk 1. The 
OLECLI.DL$ file is located in the DLL directory on Disk 2. You must manually decompress these files
from the original disks and place them in the Microsoft Windows SYSTEM subdirectory, as in the 
following example:

DECOMP A:\DLL\OLESVR.DL$ C:\WINDOWS\SYSTEM\OLESVR.DLL
DECOMP A:\DLL\OLECLI.DL$ C:\WINDOWS\SYSTEM\OLECLI.DLL

Word for Windows uses these files to perform object-linking-and-embedding functions. They must be 
in the Windows SYSTEM subdirectory in order for Word for Windows to run them.

Additional Search Words 

tshoot err msg errmsg



Restoring Drag and Drop Printing Functionality

Summary

In Microsoft Windows version 3.1, you lose the ability to drag and drop print Word for Windows 
documents from the Windows File Manager if you delete or sufficiently modify the Windows 
REG.DAT file. To restore the REG.DAT settings that enable you to perform drag and drop printing of 
Word for Windows documents, you must either rerun the Word for Windows Setup program or 
manually edit the REG.DAT file. 

More Information

The recommended method to restore the REG.DAT settings is to reinstall Word for Windows using 
the Custom Installation option. To do this, follow these steps:

1. Start the Word for Windows Setup program. For more information on using the Setup program, 
see pages 8-11 in "Microsoft Word for Windows Getting Started."

2. When prompted to choose a type of installation, choose the Custom Installation button.

3. Select the Microsoft Word check box. Clear all other check boxes, and choose the Setup button.

Word for Windows is now reinstalled and the REG.DAT settings are restored.

Reference(s)

"Microsoft Windows Resource Kit," version 3.1, pages 359-365, 454
"Microsoft Word for Windows Getting Started," version 2.0, pages 8-11

Additional Search Words 

cannot registration



Visual Basic Setup Copies Earlier OLECLI.DLL into Windows

Summary

If you set up the Microsoft Visual Basic Pro Kit after installing Microsoft Word for Windows, Visual 
Basic's earlier version of the OLECLI.DLL file overwrites the newer version of this file, which was 
installed with Word. The earlier version may cause functionality problems with OLE applications in 
Word.

The Microsoft Visual Basic Pro Kit contains version 1.0005 of OLECLI.DLL. Word for Windows ships 
with version 1.0010 of OLECLI.DLL. You must replace version 1.0005 with the later version to 
eliminate OLE functionality problems in Word.

More Information

If you are using the older OLECLI.DLL file with Word and you insert a picture or unlink an embedded 
object, double-clicking that object may delete the object or picture and leave an empty picture frame. 

Microsoft Windows Operating System Version 3.1

If you are using Windows version 3.1, expand OLECLI.DLL from the original Windows 3.1 disks, and 
place the file in the \WINDOWS\SYSTEM subdirectory. To determine the location of this file, use the 
following list:

Filename       Filename Disk Number           File Size
(Expanded)        (Compressed) 1.44 MB          1.2 MB        720K (Compd)      (Expnd)

OLECLI.DLL        OLECLI.DL_                          5                              4                A                              45422            
83456

Microsoft Windows Version 3.0

If you are using Windows version 3.0, expand OLECLI.DLL from the original Word for Windows disks 
and place the file in the \WINDOWS\SYSTEM subdirectory. 

Reference(s)

"Microsoft Word for Windows Getting Started," version 2.0, page 11
"Getting Started With Microsoft Windows," version 3.1, page 61

Additional Search Words 
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Workstation Installation Repeatedly Prompts for Disk 6

Summary

If you attempt a workstation installation of version 2.0 of Word for Windows to a subdirectory of the 
server installation of the program, Setup repeatedly prompts for Disk 6 and cannot successfully install
Word on the workstation.

More Information

For example, suppose the server installation was done to a directory named E:\WINWORD. If you 
attempt a workstation installation to a directory called E:\WINWORD\USER, during installation, Setup
prompts you to insert Disk 6 in the floppy disk drive, as if it cannot find a file that is needed from E:\
WINWORD.

Use one of these three methods to work around this problem:

Install to a directory that is not a subdirectory of the server installation.
Mark the server installation directory (E:\WINWORD in our example) read only BEFORE 

attempting the workstation installation.
Upgrade to Word for Windows version 2.0a. This problem was corrected in the maintenance 

release.

Additional Search Words 

network



Error Message: "The Directory You Typed Is Invalid..."

Summary

This error message may appear in Microsoft Word for Windows

The directory you typed is invalid or incomplete. Please type a full path with drive letter; for example 
"C:\WINWORD."

if all three of the following conditions exist:

You are installing Word for Windows on a Novell NetWare 386 server. 
You do not have create rights.
You are trying to install Word for Windows on a nonexistent directory.

More Information

During Word for Windows Setup, if you specify a nonexistent directory, this prompt appears:

The specified directory does not exist. Do you want to create the directory?

If you have Novell create rights and you choose the Yes button, Setup creates the directory. (If you 
are using Novell NetWare 286, you must have create and parental rights to create subdirectories). If 
you do not have create rights, Setup cannot create the directory and the error message appears.

To successfully run the Word for Windows Setup program, you must have Novell write, create, file 
scan, or search rights. It is advisable to log on as a supervisor because Setup adds files, writes to 
files in a number of directories, and creates several subdirectories. For more information on network 
Setup, refer to the Word for Windows README.DOC file.

Additional Search Words 

privileges 



Saving Grammar Settings with Word Installed on a Network

Summary

Network users of Word for Windows may want to keep the Grammar command files on a network 
drive to save space on workstation drives. (The GR_AM.LEX file is almost 800K; the 
GRAMMAR.DLL file is slightly more than 300K.) If the Grammar command files are located on a 
network drive, some configuration settings may not be maintained as expected. To maintain 
individual Grammar settings, copy the GRAMMAR.DLL file to the user directory.

More Information

To customize the configuration of the Grammar command, choose Options from the Tools menu, 
select the Grammar category, and adjust the settings.

There are three basic modes listed in the Use Grammar and Style Rules box: Strictly (All Rules), For 
Business Writing, and For Casual Writing. You can also select the Show Readability Statistics after 
Proofing option. The options you choose are maintained in your personal WINWORD.INI file.

You can access additional settings by choosing the Customize Settings button. Word for Windows 
maintains these settings in the GRAMMAR.INI file.

WINWORD.INI File

The Word for Windows network workstation Setup program is designed to provide each user with a 
personal directory to which the user has read, write, and create access. Various files, including the 
user's WINWORD.INI file, are stored in this directory.

The default location of the user's WINWORD.INI file depends on the type of installation you perform 
for your workstation. 

If you perform a complete or custom installation, the default location of the WINWORD.INI file is 
your Word for Windows program directory.

If you perform a workstation installation, the default location of the WINWORD.INI file is your 
Word for Windows user directory, which you specify during the installation.

In either case, the location path is stored in the [Microsoft Word 2.0] section of your WIN.INI file as 
follows:

INI-path=<path>

To verify this setting, choose Options from the Tools menu, and select WIN.INI from the Category 
box.

GRAMMAR.INI File

If you choose the Customize Settings button and change any of the settings from their default values,
Word for Windows attempts to create a GRAMMAR.INI file to store the new settings. This file is 
created in the same directory as the GRAMMAR.DLL file.

The default location of the GRAMMAR.DLL file (and GR_AM.LEX) is the WINWORD program 
directory. If this is a read-only directory, which is common with network installations, the 
GRAMMAR.INI file cannot be created. Word for Windows maintains any changes in the Customize 
Grammar Settings dialog box for the current session, but does not warn you that the GRAMMAR.INI 
file cannot be created to permanently save the changes. When you open a new session of Word, the 
default Customize Grammar Settings selections appear; any changes previously made are not 



maintained.

Workaround

You can copy your GRAMMAR.DLL file to a directory where you have write access; this allows the 
creation of an individual GRAMMAR.INI file in the same directory. The larger GR_AM.LEX file can 
remain in the original location. You can specify the new file location by modifying the Grammar path 
specification in the WIN.INI file by following these steps:

1. From the Tools menu, choose Options.

2. From the Category box, select WIN.INI.

3. From the Startup Options box, select the Grammar entry. The Grammar option displays in the 
Option box as follows:

Grammar 1033,0

Word displays the current Grammar setting in the Setting box; the default setting is

<programdir>\grammar.dll,<programdir>\gr_am.lex

where "programdir" is the setting for the programdir option shown in the Startup Options box.

4. You can change the location where Word for Windows looks for the GRAMMAR.DLL file by 
specifying the following new path to the user's directory:

<user_dir>\grammar.dll,<programdir>\gr_am.lex

Note: You must copy the GRAMMAR.DLL file from the original location to the newly-specified one.

Any subsequent changes you make to the Customize Grammar Settings dialog box causes the 
creation of a GRAMMAR.INI file to maintain the changes.

Microsoft is researching this problem and will provide new information as it becomes available.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, pages 803-805

Additional Search Words 
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Network Setup on DEC Pathworks Requires FILE SERVICE

Summary

The Microsoft Word for Windows Setup program does not recognize DEC Pathworks 4.x "DISK 
SERVICE" as a network drive. To do a network server installation in this situation, you must use a 
"FILE SERVICE" while using DEC Pathworks 4.x.

Windows considers DEC Pathworks 4.x "DISK SERVICE" to be a local disk drive, and DEC 
Pathworks 4.x "FILE SERVICE" to be a network drive.

Additional Search Words 

install workstation



Error Message: "Word Cannot Locate the Server Application..."

Summary

The following error message may appear when you attempt to edit an embedded object in Microsoft 
Word for Windows:

Word cannot locate the server application for <server application name> objects. Install the server 
application with the setup program.

This message may be caused by one of three actions:

Trying to edit information that was created in another application when Word cannot locate the 
server application. (The server application is not in the current path).

Erasing the application or moving it to another directory.
Disconnecting a link to the network in which the application is stored.

More Information

If the error message occurs on a network, verify that you are connected to the network drive, then 
use these steps to correct the problem.

1. Verify that the server application is installed.

2. Add the server application's directory to the path statement in the AUTOEXEC.BAT file.

For Windows 3.0:

Edit the path in the [EMBEDDING] section of the WIN.INI file to contain the path to the server 
application. 

Note: Using this method does not require the path to be added to the path statement in the 
AUTOEXEC.BAT file.

For Windows 3.1:

Use REGEDIT to update the REG.DAT file :

Note: Make a backup of the REG.DAT file before you edit the file. 

1. Open Program Manager. From the File menu, select Run.

2. Type REGEDIT and choose the OK button.

3. Choose the File Type you need to update (for example: Word Document).
 
4. From the Edit menu, select Modify File Type.

5. Type in the correct location in the Command box, or use the BROWSE button to locate the EXE 
file. Choose OK to make this change.

6. The changes will be written to the REG.DAT file once you Exit REGEDIT. 

Word for Windows uses information from the REG.DAT file for its object linking and embedding (OLE)
activities. In the Windows 3.1 environment, the information in REG.DAT is used when you open or 
print a file from File Manager. This information is also used by applications that support OLE. The 



registration database (REG.DAT) is set up and maintained by Windows and Windows-based 
applications. It is located in the WINDOWS directory. This file should not be moved or deleted. Doing 
so may result in loss of functionality in File Manager, Program Manager, and applications that support
OLE.

Reference(s)

Microsoft Word for Windows version 2.0 README.DOC, page 3



Files Copied During Workstation Installation

Summary

After you install Word for Windows on the server, you must complete a workstation setup for each 
Word for Windows user. The workstation installation copies the following files to the user's local or 
network use directory, depending on the directory path indicated during the workstation installation:

README DOC 22460 02-04-92      1:32p
PRINTERS DOC 48982 10-15-91      6:06p
CONVINFO DOC 62249 02-07-92    11:44a
TEMPLATE DOC 14539 10-15-91      6:06p
MACROCNV DOC 24995 10-16-91      2:53p
GRAPHICS DOC 29846 10-15-91      6:06p
PSS DOC 50435 02-04-92      7:24p
ARTICLE2 DOT 13060 01-29-92      5:39p
DISSERT2 DOT 32267 01-28-92      5:30p
LETBLOCK DOT 81701 01-28-92      5:30p
MEMO2 DOT 40127 01-28-92      5:30p
DATAFILE DOT 66318 01-28-92      5:30p
FAX DOT 10447 04-29-92    10:07a
LETMDSEM DOT  9000 01-31-92      3:01p
LETMODBK DOT  9000 01-31-92      3:01p
LETPERSN DOT  8512 01-31-92      3:01p
MAILLABL DOT 51377 04-29-92    10:07a
OVERHEAD DOT 17152 01-28-92      5:30p
PRESS DOT 12538 01-28-92      5:30p
PROPOSAL DOT 10505 10-01-91      4:58p
REPLAND    DOT 17368 01-28-92      5:30p
REPSIDE    DOT 17288 01-28-92      5:30p
REPSTAND DOT 17286 01-28-92      5:30p
TERM2 DOT 15386 10-14-91      6:00p
NEWMACRO DOC 110392 02-03-92    11:16a
WINWORD INI 63 04-29-92    10:09a
              27 file(s)          793293 bytes

The above dates and file sizes were taken from a workstation installation of Word for Windows 
version 2.0a. The sizes and dates may differ slightly if you are installing a version other than 2.0a. 

More Information

The following .DOC files are information files about the Word for Windows product. These files can 
be deleted or moved to the network server to free more disk space on local workstations.

README.DOC Information available after the publication of the manuals
in the Word for Windows package
PRINTERS.DOC Information about using printers with Word and
troubleshooting printing problems
CONVINFO.DOC Information about file conversion limitations 
and specialized conversion options
TEMPLATE.DOC Information about using the Word term paper 
and dissertation templates
MACROCNV.DOC Information about converting macros from
earlier versions of Word for Windows
GRAPHICS.DOC Information about limitations and options for 



importing graphic files into Word for Windows documents
PSS.DOC WordBasic macros written by Product Support Services
NEWMACRO.DOC Sample WordBasic macros

Other files copied during the workstation installation include the WINWORD.INI file and the Word for 
Windows template files. The WINWORD.INI file is an initialization file for the Word for Windows 
program and holds setting information for each Word user. For example, the WINWORD.INI file 
remembers whether the ribbon or ruler are "on" or "off" between sessions of Word. The sample 
template files are not required for the operation of Word for Windows and can be deleted to free more
disk space if necessary.

In addition to copying the appropriate files to the local workstation, the workstation installation also 
adds the following lines to the [Microsoft Word 2.0] section of the WIN.INI file:

[Microsoft Word 2.0]

DOC-path=C:\User
INI-path=C:\User
programdir=F:\WINWORD

The INI and DOC paths point to the workstation or local directory, while the "programdir" option 
points to the location of Word for Windows executable file on the server.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, pages 795-797
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Display and Printing Problems with Drivers After Setup

Summary

Display and printing problems sometimes arise when you run Microsoft Word for Windows in the 
Microsoft Windows operating system version 3.1 and there is a Windows version 3.0 driver present. 
Often, these problems occur after you run Windows version 3.1 Setup to upgrade from Windows 
version 3.0. The most common solution is to delete old or extraneous drivers and reinstall Windows 
version 3.1 printer or video drivers. 

Sometimes printer output is incorrect because of the presence of an old printer driver, even if the 
current printer driver is active. If you check the printer driver version number by choosing the About 
button or the Info button in the printer driver Setup dialog box, the correct version may appear, even 
when another driver is being accessed during printing.

More Information

Here are five problems that may occur in Word for Windows when a Windows version 3.0 driver is 
present on a system running Windows version 3.1:

General protection (GP) faults
Incorrect font mapping
TrueType fonts unavailable
"Garbage" printer output
Error message when you start Word for Windows

Note: If you receive the error message "Data in section 'Shell devices' in WIN.INI is corrupted or 
SHELL PRT is directly assigned," you probably have a Windows version 3.0 printer driver AND a 
Windows version 3.1 printer driver assigned to the same LPT port. This error message is generated 
because only one printer can be active at a time in Windows version 3.0.

Solution

In all cases, you must remove all old printer drivers in the Windows Control Panel and delete the old 
printer driver files from the hard disk. Then you can reinstall the correct Windows version 3.1 printer 
drivers.

Two features of Windows version 3.1 Setup contribute to the conditions described above:

Windows Setup does not replace video or printer drivers that did not ship with Windows or the 
Supplemental Driver Library (SDL). If Setup detects an OEM driver, it does not delete it.

In many cases, Windows Setup does not preserve printer driver configuration settings. (This is by
design in most cases.)

Reference(s)

"Microsoft Windows User's Guide," version 3.1, pages 201-205, 207, 210, 214

Additional Search Words
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Templates May Not Be Copied in Custom Installation

Summary

When installing version 2.0 or earlier of Word for Windows using the Setup program, you cannot copy
the supplied templates if you perform a custom installation. This is not true in Word for Windows 
versions 2.0a and later.

More Information

If you install Word for Windows using the Custom Installation option, Setup gives you a choice of 
components to install. If you select Sample Templates, you must also select the Microsoft Word 
component if you want to install all the templates. If you select Sample Templates but not Microsoft 
Word, only the MSWORD.DOT and NEWMACRO.DOC template files are copied.

Additional Search Words 

setup template



Minimum Installation

Summary

When you run the Word for Windows version 2.0 Setup program, the Minimum Installation option 
installs 5.5 megabytes of files to the selected hard disk drive. Later versions of Word for Windows 
install similarly, but size and some file names may differ. This article details what happens when you 
run the version 2.0 Minimum Installation.

More Information

Setup installs these functions, directories, and files when you select minimum installation:

Created Directories

\PROGRAMDIRECTORY default is "\WINWORD"
\WIN3\MSAPPS\MSDRAW where "WIN3" is the directory
\WIN3\MSAPPS\MSGRAPH where Windows version 3.0 is located.

Installed Functionality

Program File: WINWORD.EXE
OLE libraries
Dialog box (screen) fonts
Spelling checker
Grammar checker
Hyphenation files
Information files (README.DOC, CONVINFO.DOC, NEWMACRO.DOC, etc.)
Graphing tools (Microsoft Graph)
Drawing tools (Microsoft Draw)
Online Help

Here are the names and locations of all the files copied to the selected hard disk during a minimum 
installation: 

Program Directory: C:\WINWORD

DIALOG.FON 15680          09-11-91        9:24a
README.DOC 24008          10-16-91        6:01p
PRINTERS.DOC 48982          10-15-91        6:06p
CONVINFO.DOC 128426      10-15-91        6:06p
TEMPLATE.DOC 14539          10-15-91        6:06p
GRAPHICS.DOC 29846          10-15-91        6:06p
WINWORD.EXE 1268096    10-16-91        4:58p
SP_AM.LEX 259584      10-08-91          3:44p
HYPH.DLL 78412          09-27-91      11:43a
HY_AM.LEX 78848          06-18-91        8:09a
SPELL.DLL 108032      10-10-91      10:03a
WINWORD.HLP 1840138 10-15-91        3:01p
MACROCNV.DOC 24995          10-16-91        2:53p
WINWORD.INI 79                    10-17-91      12:36p
TOTAL 14 file(s)      3919665 bytes

C:\WIN3\MSAPPS\MSDRAW

MSDRAW.HLP 269546      08-01-91      6:21p



16COLORS.PAL 162                08-01-91      6:21p
17GRAYS.PAL  162              08-01-91      6:21p
47COLORS.PAL 238                08-01-91      6:21p
86COLORS.PAL 394                08-01-91      6:21p
GENI.PAL 410                08-01-91      6:21p
MSDRAW.EXE 574256      08-01-91      6:21p
TOTAL 7 file(s)      845168 bytes

C:\WIN3\MSAPPS\MSGRAPH

GRAPH.EXE 546304      09-24-91      3:45p
GRAPH.HLP 296643      09-24-91      3:45p
TOTAL 2 file(s)      842947 bytes

Total bytes used on disk: 5,607,780

Changes Made to the WIN.INI File

During a minimum installation some changes are made to the WIN.INI file to set up object linking and
embedding (OLE) functionality and add path information to the [Microsoft Word 2.0] section. These 
changes are: 

[embedding]

WordDocument=Word Document,Word Document,C:\WINWORD\winword.exe,picture
MSDraw=Microsoft Drawing,Microsoft
Drawing,C:\WIN3\MSAPPS\msdraw\msdraw.exe,picture
MSGraph=Microsoft Graph,Microsoft
Graph,C:\WIN3\MSAPPS\msgraph\graph.exe,picture

[Microsoft Word 2.0]

autosave-path=C:\WINWORD
INI-path=C:\WINWORD
programdir=C:\WINWORD
DOC-path=C:\WINWORD
Spelling 1033,0=C:\WINWORD\SPELL.DLL,C:\WINWORD\SP_AM.LEX
Hyphenate 1033=C:\WINWORD\HYPH.DLL,C:\WINWORD\HY_AM.LEX,C:\WINWORD\SP_AM.LEX 

Reference(s)

"Microsoft Word for Windows Getting Started," version 2.0, pages 7-11
Microsoft Word for Windows version 2.0 README.DOC.
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Installing HP LaserJet III Driver from Word 2.0 Disks

Summary

Version 2.0 of Word for Windows ships with an updated driver (version 30.3.85) for the Hewlett-
Packard (HP) LaserJet Series III printers. If your system detects a previous version of this driver 
when you install Word for Windows, the Setup program automatically updates it. You still, however, 
can install this printer driver at a later time from the Word for Windows disks.

More Information

The files on the Word for Windows disks are compressed, which means they cannot be copied 
directly over a previous driver. Use the following steps to install the HP LaserJet Series III driver from 
the version 2.0 Word for Windows disks:

1. Install the HP LaserJet III driver from the Windows 3.0 disks if the driver is not already installed 
on your system.

2. Exit Windows to the MS-DOS prompt.

3. Insert the version 2.0 Word for Windows Setup disk.

4. Copy the file DECOMP.EXE onto the root directory of the hard disk.

5. Insert the disk containing the driver files:

3.5":    Setup - Disk 1
5.25": Utilities - Disk 7

6. Type this command to decompress the necessary files into the WINDOWS SYSTEM directory:

DECOMP A:\HPPCL5A.DR$ C:\WINDOWS\SYSTEM\HPPCL5A.DRV
Note: The source path is to the floppy disk drive being accessed and the destination path is to 
the directory where Windows is located on the system.

7. This message appears:

Warning--the file 'c:\windows\system\hppcl5a.drv' exists.
Should I append to that file? Yes or No?

Type N and press ENTER.

8. This message appears:

Should I try to overwrite it? Yes or No?

Type Y and press ENTER.

9. Repeat steps 6-8 with these files from the Setup disk:

HPPCL5A.HL$
FINSTALL.DL$
FINSTALL.HL$

The corresponding names of the decompressed files are as follows:



HPPCL5A.HLP
FINSTALL.DLL
FINSTALL.HLP

The printer driver, font installer and help files are now successfully updated.

Reference(s)

"Microsoft Windows User's Guide," version 3.0, pages 158-162
"Microsoft Word for Windows Getting Started," version 2.0, page 11
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Setup Doesn't Accept Requested Disk

Summary

When you install Microsoft Word for Windows, the Setup program may prompt you for a specific disk 
but not accept that disk when you insert it. Even if the disk contains correct and uncorrupted files, 
Setup will prompt you to insert the same disk.

Workaround

If this problem occurs and the requested disk is not damaged and does contain the necessary files, 
try one of these two methods to complete the installation:

If Disk 2 is the disk that is not being successfully copied, copy the contents of Disk 1 (Setup) onto 
your hard disk into a directory called Disk1, and run the Setup program from this directory. When the 
Setup program prompts you for Disk 2, insert Disk 2 in the floppy disk drive. This may allow you to 
successfully install the remainder of the files copied from the floppy disk. If the Setup program stalls again
on a particular disk, try copying the contents of that disk to the hard disk and changing the prompt for the 
disk to the directory you created on the hard disk.

If the system has both a 5.25-inch floppy disk drive and a 3.5-inch floppy disk drive, try alternating
drives during the installation. For example, run the Setup program from the 5.25-inch drive A, but when 
prompted for Disk 2, change the drive indicator of the prompt to B:\ and insert the 3.5-inch Disk 2 in drive 
B. Continue alternating this way until the installation is complete.

Microsoft has confirmed this to be a problem in Word for Windows. We are researching this problem 
and will provide new information as it becomes available.



Setup Fails on Disk 2; Cannot Do DIR on Second Disk

Summary

If the version 2.0 Word for Windows Setup program fails after you insert Disk 2, you may need to use
the MS-DOS DRIVPARM command to correct the problem.

If a physical drive is not reading a disk properly and the disk is not physically defective, inserting the 
MS-DOS DRIVPARM command in the CONFIG.SYS file can often correct the problem. The 
DRIVPARM command modifies the parameters of an existing physical drive. It does not create a new
logical drive. The settings specified in the DRIVPARM command override the driver definitions for 
any previous block device.

More Information

The DRIVPARM command does not correct any problems with reading floppy disks if the disks are 
defective. If the disks are defective, you may have to obtain replacement disks from Microsoft 
Product Support Services.

Symptoms of Disk Drive Not Reading Properly

Place a setup disk (Disk 1) in drive A or drive B, and use the MS-DOS DIR command to display its 
directory list. Switch to Disk 2, and use the MS-DOS DIR command to display its directory. If you 
receive another directory list for Disk 1, your logical drive is reading incorrectly.

DRIVPARM Command and Its Parameters

If the logical drive is reading incorrectly, add this statement to your system's CONFIG.SYS file:

drivparm=/d:number /f:factor
where "/d:number" specifies the physical drive number.

Values for number must be 0 through 255 (/d:0 = drive A, /d:1 = drive B, /d:2 = drive C, and so on).

"/f:factor" specifies the drive type. The factor numbers for drive types are:

0 = 160K/180K or 320K/360K
1 = 1.2 megabyte (MB)
2 = 720K (3.5-inch disk)
5 = Hard disk
6 = Tape
7 = 1.44 MB (3.5-inch disk)
8 = Read/write optical disk
9 = 2.88 MB (3.5-inch disk)

Reference(s)

"Microsoft MS-DOS Operating System version 5.0 User's Guide and Reference," pages 455-457
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Cannot Change Name and Organization After Word Setup

Summary

When you install Microsoft Word for Windows, information you are prompted to enter about your 
organization is written to the Setup disk for security purposes unless you write-protect the disk before
running Setup.

More Information

When you install Word for Windows, Setup prompts you to enter the name and organization the 
product is licensed to. The information is written to the Setup disk and cannot be edited or changed 
later. This information displays as follows when you run the program, and when you choose About 
from the Help menu:

This copy of Microsoft Word is licensed to:

Name
Organization

The only way to avoid having this information written to the Setup disk is to write-protect the disk 
before running Setup. If you do this and then run Setup, you receive this error message: 

System Error

Write-protected disk in drive B:

Choose the Cancel button twice to continue with Setup.

If you enter this information but misspell it and think you may be eligible for a free set of replacement 
disks, contact End User Sales at (800) 426-9400. A representative there can determine your eligibility
for replacement disks and obtain the necessary proof of purchase documentation.

Word uses the information entered when setting up the program as the default name for the Author field 
when you choose Summary Info from the File menu. This information is editable and can be changed 
with these steps:

1. From the Tools menu, choose Options.

2. Select User Info from the list of Categories.

3. Type the new information in the Name field.

4. Choose the OK button.

This procedure changes the Author field in the Summary Info dialog box, but not the licensee name.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, page 735
"Microsoft Word for Windows Getting Started," version 2.0, page 8



Modification of WWORD20.INF Is Not Supported

Summary

Microsoft does not support modification of the setup information file, WWORD20.INF, for Microsoft 
Word for Windows. Although this is a text file, modifying it is not recommended because it requires an
advanced knowledge of programming. Microsoft Product Support Services does not have information
on WWORD20.INF and cannot assist with its modification. 

More Information 

Microsoft University offers a course that provides some information on modifying Windows setup 
information files. For more information, contact Microsoft University at (206) 828-1507.



Minimum Files Needed to Run Word Version 2.0

Summary

As a minimum, you can run versions 2.0, 2.0a, and 2.0b of Word for Windows with only the files listed
below:

WINWORD.EXE
SHELL.DLL*
OLECLI.DLL*
OLESVR.DLL*
VER.DLL

The three files with an asterisk (*) are object-linking-and-embedding (OLE) DLL files that can be 
eliminated if you are running Windows version 3.1. COMMDLG.DLL is the DLL that provides common
dialogs when using Windows 3.1.

Additional Search Words 
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Running Setup in the Background

Summary

You can run Word for Windows Setup in the background if you want to continue working on your 
computer during installation.

More Information

If you press CTRL+ESC during the installation of version 2.0 of Word for Windows, the Task List 
displays and you can switch to another application such as Excel.

Working in another application slows the installation process somewhat, but you can continue to 
work. Setup runs in the background without any problems. 



Decompressing Word Files

Summary

Microsoft Word for Windows files are shipped compressed, and are automatically decompressed by 
the Setup program. This article explains how to decompress them without running Setup. 

More Information

You can decompress Word for Windows files with the DECOMP.EXE utility program provided with 
Word for Windows on one of the following disks:

Word for Windows versions 2.0 and later

3.5-inch, 5.25-inch disks    -> Disk 1

Word for Windows versions 1.x

If you have 3.5-inch high-density disks    -> Conversions Disk
If you have 3.5-inch low-density disks      -> Setup Disk
If you have 5.25-inch high-density disks -> Conversions Disk
If you have 5.25-inch low-density disks    -> Disk 1

To decompress a file with DECOMP.EXE, use these parameters

Usage:  decomp [-afq] srcFile [destFile]
-a appends to the destination file, if it exists.

-f forces overwriting if the destination file exists. (Files can't be decompressed on top of themselves.)

-q calculates the size of the uncompressed file (no output).

You can specify a directory instead of a filename for destFile. If you do not specify a filename for 
output, a name will be constructed from the base and extension stored in the header and/or the 
srcFile name if the header does not include filename information.

Example:

decomp Courb.fo$ c:\winword\Courb.fon
where:

srcFile is the source file, such as "Courb.fo$."

destFile is the destination file, such as "Courb.fon."

a, f, q are the optional parameters described above.

For more information on decompressing files, please refer to the README.TXT file located on the 
Word for Windows Setup disk.

Reference(s)

README.TXT. Word for Windows version 1.1, Setup disk.
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Troubleshooting Corrupted Documents in Word for Windows

Summary

Corrupted document files can cause any application to exhibit unusual behavior as it attempts to 
select and complete actions based on incorrect information.

This article provides troubleshooting procedures you can use to identify, recover, or prevent 
corruption of Microsoft Word for Windows document files.

Identifying a Corrupted Document

Corrupted documents often exhibit behavior that is not part of the program's design (for example, 
infinite repagination, incorrect document layout and formatting, unreadable characters on the screen, 
error messages during processing, system hangs or crashes when you load or view the file, or any 
other unusual behavior that cannot be attributed to the normal operation of the program). These 
behaviors can be caused by factors other than document corruption. To rule out other factors, use 
these troubleshooting steps:

Check for similar behavior in other documents.
Check for similar behavior in other applications.
Take the file in question to another machine and attempt to duplicate the behavior.
Use a different printer driver and attempt to duplicate the behavior.
Rename WINWORD.INI and NORMAL.DOT, then attempt to duplicate the behavior.

Note: WINWORD.INI and NORMAL.DOT can also be corrupted; you should always check out this 
possibility during initial troubleshooting.

Rename any templates attached to the document and attempt to duplicate the behavior.
Change other system components (such as video drivers or fonts) and attempt to duplicate the 

behavior. For example, if you are using an OEM version of a video driver, switch to a Microsoft Windows 
video driver using the Windows Setup program.

Disable any third-party programs that are running (such as terminate-and-stay-resident programs 
[TSRs], font managers, screen savers, and system shells), then attempt to duplicate the behavior.

If the problem occurs only with a single document after performing these steps, your document has 
probably been corrupted.

Correcting a Corrupted Document

A backup copy of the document is the best way to recover it; make backups regularly. If you have no 
backup, there are several techniques you can use to try to correct a corrupted document. Which 
method you use depends on the nature and severity of the corruption and the nature of the behavior 
exhibited. Although many of these methods succeed regularly, not every corrupted document can be 
recovered.    

1. Convert the file to another format, then convert it back to native format.

This is the easiest and most complete document recovery method; always try it first. Save the 
file in RTF file format, which preserves formatting. After you save the file in RTF format, reopen 
the document in Word for Windows, and convert it from RTF. If this method succeeds, the file 
corruption is removed during conversion. If the corruption persists after you save the file in RTF 
file format, try saving the file in other word processing formats. 

If none of these works, try saving it in Text Only format. Saving files in Text Only format 



frequently corrects document corruption, but it removes all document formatting. If you have 
significant amounts of formatting in a sizeable corrupted document, try all the other methods 
before this one. 

2. Copy everything except the last paragraph mark to a new document.

Word for Windows associates a wide variety of formatting with the last paragraph mark, 
especially section and style formatting. If you copy everything except the last paragraph mark to 
a new document, the corruption may be left behind in the original document. In the new 
document, reapply the section or style formatting.

Note: You can select everything except the last paragraph mark by pressing CTRL+END, then 
CTRL+SHIFT+HOME.

3. Copy the uncorrupted portions of the document to a new document.

Sometimes you can determine the location of file corruption in your document. In such cases, 
copy everything except the corrupted portion to a new file, then use these steps to reconstruct 
your document:

a. After you copy the uncorrupted portions of your document to a new file, save a copy of the 
corrupted document in Text Only format.

b. Open the Text Only file. Copy the text from this file and paste it in the file that contains the 
uncorrupted portion of your document.

c. Reformat the sections you pasted in step b, then save the recovered document.

4. Strip out the file header information.

Use this method only if all other methods fail. When you cannot open a corrupted document in 
Word for Windows (usually because of corruption in the file header), you can strip out the file 
header and open the file as Text Only. When you strip the header information, all formatting is 
lost.

a. At an MS-DOS prompt, type the following, then press ENTER

COPY CON+FILENAME.DOC NEWNAME.DOC

where "FILENAME" is the name of the corrupted file, and "NEWNAME" is the name of the new 
file. (This causes the word "CON" to appear and the cursor to blink on a blank line.)

c. Press the SPACEBAR twelve times.

d. Press F6, then press ENTER.

e. Launch Word for Windows and open the new file.

f. Delete the foreign characters at the beginning and end of the file. The text of the file is usually
intact in the middle of the file.

g. Reformat the document and save it in Word for Windows format.

Note: If the file was saved in Word for Windows with the Allow Fast Saves check box selected, the 
text appears in discontiguous blocks. You must reorder the text and then reformat it. 



5. Open the file in Microsoft Write to strip out the file header information.

a. Go to the Microsoft Windows Program Manager. From the File menu, choose Run.

b. In the Command Line box, type "write" (without the quotation marks), and choose the OK 
button to start the Microsoft Write application.

c. From the File menu, choose Open.

d. In the File Name box, type the path and filename of the corrupted Word for Windows 
document. Choose the OK button. For example, if the corrupted document is named 
PAPER.DOC and resides in the Word for Windows directory on drive C, you would type:

\winword\paper.doc
e. A dialog box prompts you to specify how you want to convert the file. Choose the No 

Conversion button.

f. The Word for Windows document is now open as a text file. You should see binary (foreign) 
characters at the beginning and end of the document. Delete them.

g. From the File menu, choose Save As. Type a new name with a .DOC extension in the File 
Name box. Before choosing the OK button, note the directory where the file is being saved so
you can easily find it when you restart Word for Windows.

h. From the File menu, choose Exit.

i. Restart Word for Windows. From the File menu, choose Open.

j. In the File Name box, type the path and filename of the newly created file, and choose the OK
button.

k. In the Convert File dialog box, Text Only should be selected. Choose the OK button to open 
the text file in Word for Windows.

l. From the File menu, choose Save As.

m. In version 2.0 of Word for Windows, select Word Document (*.doc) in the Save File As Type 
box. In Word for Windows versions 1.x, choose the Options button and select Normal in the 
File Format box.

n. Type a new name with a .DOC extension in the File Name box, and choose the OK button. 
The file is now in Word for Windows Normal format. You can reopen it and replace any 
necessary graphics, fields, and formatting. 

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, page 676
"Microsoft MS-DOS User's Guide and Reference," version 5.0, page 391
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Corrupted Document Causes UAE/GP Fault During File Conversion

Summary

Microsoft Word for Windows may produce an unrecoverable application error (UAE) or general 
protection (GP) fault if you attempt to convert a corrupted file.

More Information

In Word for Windows, when you open a document with a format other than Normal, Word displays 
the Convert File From dialog box. All the file converters installed for Word for Windows display in this 
dialog box. The appropriate converter should already be selected; choosing the OK button initiates 
the conversion process.

If the file you want to convert is corrupted or damaged in any way, a UAE or (GP) fault may occur. 
After receiving a UAE or GP fault, you should exit Windows and restart your machine to reset the 
computer's memory.

Data from corrupted documents can sometimes be recovered. There are third-party utility programs 
designed to do this. If you do not have access to such tools, you can use the MS-DOS COPY CON 
command.

Microsoft has confirmed this to be a problem in Word for Windows. We are researching this problem 
and will provide new information as it becomes available.

See Also
Troubleshooting Corrupted Documents in Word for Windows

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, pages 675-679
"Microsoft Word for Windows Getting Started," version 2.0, pages 8-10, 30
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Troubleshooting GP Faults (UAEs)

What Is a General Protection (GP) Fault?

A general protection (GP) fault in Windows 3.1 (referred to as an unrecoverable application error 
[UAE] in Windows 3.0) occurs only in standard and 386 enhanced mode. A GP fault signifies that 
something unexpected has happened within the Windows environment, usually an improper memory 
access. In other words, something running within the Windows environment has made a call to a 
location in memory that it did not have access to, potentially overwriting and corrupting other program
code in that area of memory. More specifically, an application or Windows component might read or 
write to a memory location that it has not been preallocated, or memory that it does not "own." All 
memory management within Windows is handled by the Windows environment itself, and when 
applications and Windows components directly access memory, the result is often a GP fault.

Another situation where a GP fault may occur involves the passing of parameters between 
applications and the Windows environment. Invalid parameters affect the performance of Windows 
and its applications by forcing an invalid instruction. This is usually the result of an application's 
internal program code incorrectly passing specific data that could not be correctly interpreted for 
Windows or another Windows-based application. The result is often a GP fault.

What Is a System Integrity Violation?

A system integrity violation is a general protection violation, or the equivalent of a GP fault that is 
caused by an MS-DOS-based application. Similar to the GP fault, the system integrity violation 
indicates that an MS-DOS-based application is accessing memory that does not belong to that 
specific application. Since Windows is managing memory in this situation, the MS-DOS-based 
application's memory access will often corrupt Windows program code or vital data. The result is an 
application execution error generated from Windows reporting that the "application has violated 
system integrity due to an invalid general protection fault and will be terminated." This message can 
also occur when an MS-DOS-based application has tried to access a system's hardware component 
directly.

How Does Windows 3.1 Handle a GP Fault?

A new feature of Windows 3.1 called parameter validation allows Windows to check for invalid 
parameters passed between Windows and applications running in the Windows environment. 
Windows 3.1 is also designed to better manage and maintain which applications "own" specific 
memory locations and system resources. As a result, Windows 3.1 is more capable of recovering a 
particular application's RAM memory and system resources. If you do see a GP fault message while 
running Windows 3.1, its message will provide specific information about which applications and 
Windows components were running at the time of the error, and where the error occurred. Depending
on the severity of the GP fault, Windows 3.1 can continue to run the application that caused the fault, 
allowing you to save your work before exiting the application. You can also use Dr. Watson, a 
program provided with Windows 3.1, to learn more about the cause of the GP fault.

Local Restart

Depending on the severity of a GP fault in Windows 3.1, you can press CTRL+ALT+DEL to display 
information concerning the system integrity and/or information concerning the application that caused
the fault. You can assess a GP fault's severity by noting how well an application functions within the 
Windows environment after the fault has occurred. If CTRL+ALT+DEL is pressed when a less severe 
fault occurs, this appears on the screen:

System has either become busy or has become unstable

1. Press any key to return to Windows and wait



2. Press CTRL+ALT+DEL again to restart your computer (all unsaved information will be lost)

If you press CTRL+ALT+DEL when a more severe fault occurs, this message appears:

This Windows application has stopped responding to the system 

1. Press ESC to cancel and return to Windows
2. Press ENTER to close this application (all unsaved information will 
3. Press CTRL+ALT+DEL again to restart your computer (all unsaved information will be lost)

Troubleshooting GP Faults

1. If you are running Windows in standard or 386 enhanced mode, check to see if you are running 
an application that was designed for an earlier version (2.x) of Windows.

Applications not properly designed to function under Windows protected mode cause errors. If 
an application is designed for Windows versions 2.0, 2.03, 2.1, and 2.11, it generates a dialog 
box when executed that advises you of this error. Such applications should be run only under 
Windows 3.0 real mode, as the dialog box suggests. Since real mode is not available in 
Windows 3.1, contact the application's manufacturer for possible workarounds or to obtain an 
upgrade.

2. Check for incompatible terminate-and-stay-resident (TSR) programs or unsupported device 
drivers in your CONFIG.SYS or AUTOEXEC.BAT file.

Temporarily comment out all lines relating to suspect drivers and TSR programs to bring the 
system to a minimum configuration for testing purposes. (To comment out a line, use a text 
editor such as Notepad, open the AUTOEXEC.BAT or CONFIG.SYS file, and type "rem" [without
quotation marks] at the beginning of the line.) If this eliminates the problem, then the problem 
was related to one of the drivers or TSR programs that was commented out. Reinstate the 
removed lines one by one until the problem reappears, thus showing which line was loading the 
TSR program or driver that was causing the error.

Minimum MS-DOS configuration for Windows versions 3.0 and 3.1:

CONFIG.SYS                                                           AUTOEXEC.BAT  

files=50 path c:\;c:\dos;c:\windows
buffers=30 prompt $p$g
device=c:\[path]\himem.sys set temp=c:\
stacks=9,256 Windows 3.1 only)

Note: When modifying files, make sure you don't comment out lines pertaining to other 
hardware-specific device drivers, such as Stacker, extended memory boards, third-party disk 
partitioning programs, and so on. If you do not know the purpose of a line in your CONFIG.SYS 
or AUTOEXEC.BAT file, leave that line as is.

3. Try different machine switches for the HIMEM.SYS device driver in your CONFIG.SYS file.

HIMEM.SYS is used to access the high memory area (HMA), which is the first 64K of extended 
memory (1024K-1088K). HIMEM.SYS is also the default device driver Windows uses to access 
extended memory in standard and 386 enhanced modes. HIMEM.SYS accesses the HMA 
through the A20 line of memory and uses what are known as A20 "handlers" to do this. The 
method used to access the HMA depends on the system, so the A20 handler needed for this 
access varies as well. HIMEM.SYS follows a certain routine at load time to determine which A20 
handler is appropriate for your machine. 



Unfortunately, some nonstandard machines do not respond to the tests that HIMEM.SYS 
administers during its routine, so the wrong A20 handler is selected. Using the incorrect A20 
handler can result in everything from the machine stopping when HIMEM.SYS loads, to erratic 
Windows performance. The /MACHINE switch is used to gain control of the A20 line by forcing 
HIMEM.SYS to use a particular handler. The handler numbers range from 1-16, and 18. For 
most 100-percent-compatible machines, one of the compatible /M:1, /M:11, /M:12, and /M:13 
A20 handler switches will work. Although other switches are intended for use with certain 
hardware, one of these other switches may be required for proper operation on certain machines
if the standard switches do not work. It is recommended that you check your most current MS-
DOS or Windows manual for more information about using the /MACHINE switch with 
HIMEM.SYS. Examples of this statement in the CONFIG.SYS file:

device=c:[\path]\himem.sys /machine:1
device=c:[\path]\himem.sys /m:1

Note: When you are testing to see which A20 handler is appropriate, make sure you have a 
system (startup) MS-DOS disk with an ASCII text editor (such as MS-DOS Edit or Edlin), 
because some A20 handlers will cause your machine to stop booting from the hard disk.

4. Check to see if an incorrect machine and/or network was selected while installing Windows.

Some machines and networks require you to override the default detection made by Windows 
Setup and make a specific selection. If the correct selection is not made, Windows will not 
operate correctly, or a GP fault may occur.

Machines that must be specifically selected in Windows Setup include:

Windows
Machine 3.0 3.1

AST: all 80386-
    and 80486-based machines X X
AT&T PC X
AT&T NSX 20: Safari Notebook X
Everex Step 386/25 (or compatible) X X
Hewlett-Packard: all machines X X
IBM PS/2 Model 70P X
IBM PS/2 Model L40sx X
Intel 386SL-based system with APM X
MS-DOS system with APM X
NCR: all 80386-
    and 80486-based machines X
NCR PC386sx X X
NCR PC 925 X
NEC PowerMate SX Plus X X
NEC ProSpeed 386 X X
Toshiba 1200XE X
Toshiba 1600 X X
Toshiba 5200 X X
Zenith: all 80386-based machines X X

Networks that must be specifically selected in Windows Setup include the following:

Windows
Network 3.0 3.1



3Com 3+Open LAN Manager 
(XNS only) X
3Com 3+Open X
3Com 3+Share X X
Artisoft LANtastic X
Banyan VINES 4.0 X X
DEC Pathworks X
IBM OS/2 Lan Server X
IBM PC LAN Program X X
LAN Manager versions 1.x
    or 100-% compatible) X X
LAN Manager 2.0 
    (or 100-percent compatible) X X
LAN Manager 2.1 
    (or 100-percent compatible) X
Novell NetWare X
TCS 10NET X

If you did not choose your machine or network specifically during Setup, you should exit 
Windows and run the MS-DOS version of Setup from the WINDOWS directory. This will allow 
you to make the proper selection without having to reinstall Windows completely. 

5. A third-party Windows device driver may not be functioning properly. Run the MS-DOS version of
the Windows Setup program and select the lowest level configuration of drivers for the listed 
hardware devices.

A good troubleshooting technique is to configure Windows through Setup for the minimum 
necessary hardware devices. When troubleshooting GP faults, only standard Windows device 
drivers are recommended. For example:

Display: EGA or VGA, depending on video type (systems with VGA
cards/monitors can usually use EGA)

Mouse: No mouse or other pointing device
Network: No network installed

 
6. Check for unsupported third-party drivers in the Windows SYSTEM.INI or WIN.INI files.

Temporarily comment out all lines relating to suspect third-party drivers to bring Windows to a 
minimum configuration for testing purposes. (To comment out a line, use a text editor such as 
Notepad, open the SYSTEM.INI or WIN.INI file, and type "rem" [without quotation marks] at the 
beginning of the line.) If this eliminates the problem, then the problem was most likely caused by 
one of the drivers that was removed. Replace the removed lines one by one until the problem 
reappears, thus showing which line was causing the problem. The installation of certain 
applications may modify these two files to enhance the overall functionality of Windows or 
provide additional features to the Windows environment. The statements below are the most 
commonly altered by third-party software manufacturers. As a result, verify the minimum default 
Windows configuration.

Check the following statements to verify the default Windows configuration of the most 
commonly altered statements:

SYSTEM.INI                                                WIN.INI  

[boot] [windows]
shell=progman.exe load=



system.drv=system.drv run=
keyboard.drv=keyboard.drv
mouse.drv=mouse.drv
display.drv=vga.drv

7. Your system may have a page-mapping conflict in 386 enhanced mode.

Page-mapping conflicts occur only in 386 enhanced mode Windows, most frequently in Windows
3.0. Windows 3.0 often does not see the page frame or upper memory block mapping performed
by 386 expanded memory managers (EMMs) and maps over those memory locations. Windows 
3.1 inherits the upper memory area (UMA) mapping information from the EMM, so it does not 
map over memory locations used by the EMM. However, both Windows 3.0 and 3.1 can 
experience page-mapping conflicts with other devices or applications that use the UMA. Test the 
problem under standard mode by running Windows with the /s switch from the command prompt 
(type "win /s" [without quotation marks]).

If the problem does not occur in standard mode, it may be a page-mapping conflict in the 
adapter segment area of memory (between 640K and 1 MB). Edit the SYSTEM.INI file with 
Notepad or SysEdit and insert this line in the [386Enh] section:

EMMExclude=A000-EFFF                (This line is not case sensitive.)

Note: Because Windows 3.1 inherits its mapping information from any EMM loaded before 
Windows, it is important either to disable the EMM or exclude the same memory range (as 
shown above) with the EMM itself. Mapping information inherited from the EMM overrides any 
entries in the SYSTEM.INI file.

Performing the step described above will exclude the entire adapter segment from mapping. If 
making this change solves the problem, you may want to determine the position of all hardware 
adapters in the adapter segment and exclude them specifically, rather than excluding the entire 
region. You can use multiple EMMExclude lines if necessary. If you are using a Micro Channel 
Architecture (MCA) bus machine such as an IBM PS/2, you can determine the adapter location 
by restarting with the machine's reference disk.

If you are using an Industry Standard Architecture (ISA) bus machine, consult your adapter 
documentation and/or your manufacturer's technical support service for information on the 
memory locations the bus machine uses. You will not want to leave the entire range excluded, 
because Windows cannot use any of the memory addresses in that range to set up such things 
as expanded memory for MS-DOS-based applications.

Windows 3.1 Only: Use the command "win /3 /d:x" (without the quotation marks) to load 
Windows from the command prompt. The /d:x switch excludes the memory range A000-EFFF 
from mapping, similar to the statement EMMExclude=A000-EFFF in the [386Enh] section of the 
SYSTEM.INI file. However, as with the EMMExclude= statement, this switch is overridden by 
any settings inherited from an external EMM. It is best to disable such EMMs if possible. 

8. Check the MS-DOS version you are running.

A machine should have the proper MS-DOS version for its hardware type. Original equipment 
manufacturer (OEM) versions of MS-DOS such as COMPAQ MS-DOS or IBM PC-DOS should 
be used only on their respective OEM hardware platforms (that is, COMPAQ MS-DOS only on 
Compaq machines, IBM PC-DOS only on IBM machines).

9. If you have a permanent swap file set up in Windows, it may be corrupted.

The integrity of a permanent swap file is important if these errors continue. If the location of the 



swap file contains bad sectors, an error can occur. Windows assumes the data area of the swap 
file is valid, but if code is swapped to a corrupted area, the data becomes corrupted. Change the 
swap file to a temporary swap file and restart the machine after first turning the computer 
completely off. It may also be necessary to run a disk optimization/defragmentation utility to 
improve the performance of the Windows swap file.

10. Reinstall the software causing the GP fault.

If the GP fault can be tracked to a specific application, you may need to reinstall that software. 
The files on disk may have become corrupted or damaged or the application may not be properly
installed. You may also have to reinstall Windows. If the SYSTEM.INI or WIN.INI file has been 
modified with poor results, a new installation of Windows ensures a clean, unaltered Windows 
configuration.

If you have tried all the above troubleshooting techniques and GP faults or UAEs still are 
occurring, you may have to contact your hardware/software supplier for more information. 

Additional Search Words

tshoot gpf win segment load failure



GP Fault or UAE When You Double-Click Toolbar

Summary

Microsoft Word versions 2.0 and 2.0a for Windows generate either a General Protection (GP) fault in 
Windows 3.1 or an Unrecoverable Application Error in Windows 3.0 if you do any of these things: 

1. Start Word for Windows without a default document.

2. Double-click a blank area on the toolbar to activate the Toolbar category of the Options dialog 
box.

3. Under Category, select View.

4. Choose the OK button without making any changes.

Workaround

Avoiding the actions described in 2, 3, and 4 above will avoid the problems they cause. It is possible, 
however, to launch Word 2.0 or 2.0a without a default document: select the Word for Windows icon, 
and add the /n switch to the end of the Command Line in the Program Item Properties dialog box. For
example:

C:\WINWORD\WINWORD.EXE /n

Microsoft has confirmed this to be a problem in Word versions 2.0 and 2.0a for Windows. We are 
researching this problem and will provide new information as it becomes available.

Additional Search Words 

GPF win31 crash hang lock



 Printing Merged Landscape Document Hangs System

Summary

If you are running Microsoft Word for Windows in Windows 3.1 and you print a merged document that
is formatted for landscape orientation using the HP LaserJet Series III printer driver version 31.3.89 
for Windows 3.1, your system may hang.

More Information

If a print merge main document is formatted for landscape orientation, the merged document will also
be formatted for landscape orientation. To create a merged document, select the Merge To New 
Document option button under Merge Results in the Print Merge dialog box. The merged document 
window title will be Form LettersN (where "N" is a number). If the active printer driver is the HP 
LaserJet Series III, version 31.3.89, your system may hang when you print this merged document.

Each record in the Form LettersN merged document will be separated by a next-page section break. 
Each section will be formatted for landscape orientation except the last section. You must change this
section to landscape formatting to print the last record correctly.

Steps to Reproduce Problem

Note: This procedure may cause your Windows system resources to be rapidly depleted. To check 
your available system resources, choose About Program Manager from the Help menu in Windows 
Program Manager. If your system resources are low, exit and restart Windows to restore these 
resources. If you restart Word for Windows without exiting and restarting Windows, you may receive 
the following error message:

General Protection (GP) Fault
Application Execution Error
Insufficient Memory to run...

1. Create a new Word for Windows document based on NORMAL.DOT. (This document will be the 
print merge main document.)

2. From the Format menu, choose Page Setup. Select the Size and Orientation option button. 
Select the Landscape option button, then choose the OK button.

3. From the File menu, choose Print Merge.

4. Choose the Attach Data File button, select your data file, and choose the OK button.

-or-

Choose the Create Data File button and create a new data file. For more information on creating 
a data file, refer to pages 612-620 in the "Microsoft Word for Windows User's Guide."

5. Activate the main document (the document created in step 1). Choose the Insert Merge Field 
button on the print merge bar. Select a field in the Print Merge Field box and choose the OK 
button.

6. From the File menu, choose Print Merge. Choose the Merge button.

7. In the Merge Results box, select the Merge To New Document option button and choose the OK 
button. The merged document is now the active window.



8. From the File menu, choose Print. Choose the OK button. The Printing dialog box appears, but 
you cannot choose the Cancel button. The system is frozen.

9. Exit Word for Windows by pressing CTRL+ALT+DEL. When the Windows message screen 
appears, press ENTER to close Word for Windows.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, pages 609-656, 667-674

Additional Search Words

lock locked crash hung hangs halted leaking gpf out of memory low



GP Fault Occurs When You Insert a File in a Framed Table

Summary

In Microsoft Word for Windows, a General Protection (GP) fault error is generated if you:

1. In Word for Windows, create a new file, and type several lines of text. Select a portion of the text.

2. From the Insert menu, choose Bookmark. Type a name for the bookmark, and choose the OK 
button.

3. From the File menu, choose Close. When prompted, choose the Yes button to save changes to 
the file.

4. Create another new file. From the Table menu, choose Insert Table, and choose the OK button. 
Position the insertion point in the table. From the Table menu, choose Select Table.

5. From the Insert menu, choose Frame.

6. Position the insertion point in the framed table. From the Insert menu, choose File. Select the file
you saved in step 3. In the Range box, type the name of the bookmark you inserted in step 2. 
Check the Link To File check box and choose the OK button.

More Information

Microsoft is researching this problem and will provide new information as it becomes available.

Additional Search Words 

GPF win31



AUTOSAVE-Path Defaults to the Word Program Directory

Summary

When using the Word for Windows Automatic Save feature, Word creates a file with the 
extension .ASD in the location specified by the "AUTOSAVE-path=" line in the [Microsoft Word 2.0] 
section of the WIN.INI file. You can use this file to recover a document after an unrecoverable 
application error (UAE) or accidental shutdown of the computer.

The default setting for the "AUTOSAVE-path=" line is the Word for Windows directory.

To turn on the Automatic Save feature, follow these steps:

1. From the Tools menu, choose Options.

2. From the Category box, choose Save.

3. Automatic Save every x minutes (where x is the time specified between saves).

To set the directory location for "AUTOSAVE-path=", follow these steps:

1. From the Tools menu, choose Options.

2. From the Category box, select Win.ini.

3. From the Applications list box, select Microsoft Word 2.0.

4. From Startup Options, select "AUTOSAVE-path=."

5. In the Setting text box, type a valid drive and directory location (do not use a RAM drive because
this type of drive is volatile, meaning it will not exist if the power goes off).



UAE/GP Fault Occurs When Running Spelling Checker in Word Footer

Summary

When you run the Word for Windows Spelling checker on a document that contains a misspelled 
word in both the header and the footer, an unrecoverable application error (UAE) or general 
protection (GP) fault occurs when the spelling checker begins to check the footer. The header and 
footer must BOTH contain misspelled words to generate the UAE or general protection (GP) fault.

Microsoft has confirmed this to be a problem in version 2.0 of Word for Windows. This problem was 
corrected in Word for Windows version 2.0a.

New or updated Microsoft products can be obtained from Microsoft End User Sales at (800) 426-
9400. If you are outside the United States, contact your local Microsoft subsidiary. To locate your 
subsidiary, call Microsoft International Customer Service at (206) 936-8661.

More Information

In version 2.0 of Word for Windows, the spelling checker checks the entire document, including 
headers, footers, annotations, and footnotes (unless you select a portion of the text before running 
the spelling checker). If you position the insertion point in the body text and choose Spelling from the 
Tools menu, the spelling checker checks the document in this order:

1. Body text
2. Footnote
3. Header
4. Footer
5. Annotations

If you choose the Spelling command when the insertion point is positioned in a header pane, it 
checks only the header text. This is also true for the footer, footnote, and annotation panes.

You must display hidden text before checking its the spelling. To do this, choose Options from the 
Tools menu, select the View category, and select the Hidden Text check box. 

Workaround

To avoid receiving an unrecoverable application error when using the spelling checker in a footer, use
one of the following methods:

Method 1

Position the insertion point in the footer, and run the spelling checker. Position the insertion point in 
the body text, and run the spelling checker on the rest of the document. 

Method 2

Select the entire document (CTRL+Keypad 5) before you run the spelling checker. This ensures that 
the Spelling command checks only the body text of the document and then displays the following 
message:

Word finished checking the selection. Do you want to continue checking the remainder of the 
document?

Choose the No button to avoid checking the footer and receiving a UAE or general protection (GP) 
fault. You can use the spelling checker on the header and footer separate from the body text using 



the first method.

Method 3

Format the footer for no proofing by following these steps:

1. From the View menu, choose Header/Footer.

2. Select Footer, and choose the OK button.

3. Select the contents of the footer. From the Format menu, choose Language.

4. From the Mark Selected Text As box, select the (no proofing) option, and choose the OK button.

This stops the spelling checker from checking the footer.

Steps to Reproduce Problem

Note: The following steps assume you are working in normal view. From the View menu, choose 
Normal to switch views.

1. In a new document, type the word "body text" (without the quotation marks) in the body of a 
document.

2. From the View menu, choose Header/Footer. From the Header/Footer dialog box, select Header,
and choose the OK button. Type the word "hedder" (without the quotation marks) in the header.

3. From the View menu, choose Header/Footer. From the Header/Footer dialog box, select Footer, 
and choose the OK button. Type the word "footerr" (without the quotation marks) in the footer. 
From the footer icon bar, choose the Close button.

4. Press CTRL+HOME to move the insertion point to the beginning of the document.

5. From the Tools menu, choose Spelling.

6. The spelling checker indicates that "hedder" is misspelled; choose the Change button. Next, the 
spelling checker indicates that "footerr" is misspelled, and displays this message followed by the 
Cancel and Retry buttons:

RECOVERABLE APPLICATION ERROR. MSWORD failed in MSWORD.
Ignoring fault is risky.

Reference(s)

"Microsoft Word for Windows User's Guide," version 2.0, page 276

Additional Search Words 

cursor



Hidden Temporary Files Left on Hard Disk

Summary

If you do not exit Word for Windows properly, hidden temporary files are written to the current 
directory (the directory of the open Word for Windows file). An improper exit occurs if your system 
locks up, the power is lost or turned off while Word is active, or you encounter an unrecoverable 
application error (UAE) or general protection (GP) fault. Any of these occurrences leave hidden 
temporary files on your system. Temporary files have a .DOC extension, and their filename begins 
with the tilde character (~).

More Information

If you have hidden temporary files on your system, you may notice a loss of disk space. You also 
cannot delete any directory that contains these hidden files. To display and change the attribute of 
hidden files from Windows version 3.0 File Manager, choose Include from the View menu, and select 
the Show Hidden Files check box. 

To change file attributes in Windows version 3.1 File Manager, display the hidden files by choosing 
By File Type from the View menu and selecting the Show Hidden/System Files check box. Select the 
flagged hidden file. From the File menu, choose Properties, and clear the Hidden check box.

You can also locate these files with the MS-DOS ATTRIB command (type "attrib \~*.* /s" at the MS-
DOS prompt). Clear the hidden attribute using the ATTRIB command. Type "ATTRIB -h 
{filename.ext}" at the MS-DOS prompt.

Note: Temporary files have a file size of 51 bytes. They contain the current user information and a 
one-directory reference. 

Word for Windows uses its temporary files to store information about who is currently using a file. 
This information is useful in a network environment: when someone tries to open a file that is already 
being accessed by another user; Word looks at the temporary file to see who is using the file and 
returns that information to the requester.

You can prevent Word for Windows from creating this hidden temporary file by adding the line 
"NoOwnerFiles=YES" to the [Microsoft Word 2.0] section of the WIN.INI file with these steps:

1. From the Tools menu, choose Options.

2. Under Category, select WIN.INI.

3. From the Application box, select Microsoft Word 2.0.

4. In the Option box, type "NoOwnerFiles" (without the quotation marks).

5. In the Setting box, type "Yes" (without the quotation marks).

6. Choose the Set button, then choose the Close button.

7. Exit Word for Windows. Restart the program to activate the change.

The "NoOwnerFiles" setting prevents Word for Windows from attempting to write a temporary owner 
file when opening a file.

Reference(s)



"Microsoft Word for Windows User's Guide," version 2.0, pages 798-802

Additional Search Words 

crash hang



UAE/GP Fault with Undefined Field Argument in WordBasic Macro

Summary

In Microsoft Word for Windows, if a line in a WordBasic macro contains a field argument without a 
reference to the field, an unrecoverable application error occurs (UAE) or general protection (GP) 
fault.

More Information

Three WordBasic commands result in unrecoverable application errors:

Dim a(2)
= 42
Print a(1) .BasedOn

Workarounds

If you omit the .BasedOn field, the WordBasic macro operates correctly. Another way to avoid this 
error is to include the following set of command lines:

Begin Dialog UserDialog 320, 144, "Microsoft Word"
TextBox 10, 6, 160, 18, .BasedOn
End Dialog
Dim dlg As Dialog UserDialog
Dim a(2)
a(1) = 42
Print a(1); dlg.BasedOn

Microsoft is researching this problem and will provide new information as it becomes available.

Reference(s)

"Microsoft Word for Windows Technical Reference," pages 31, 96
"Microsoft Word for Windows and OS/2 Technical Reference," pages 133, 269

Additional Search Words

uae parameter argument defined



Embedding an Object Within an Object in Header/Footer

Summary

In Word for Windows, either an unrecoverable application error or a recoverable application error 
occurs if you embed objects multiple layers deep in the header/footer area.

Note: Before reproducing this problem, save all editing changes in any open files.

Steps to Reproduce Problem

Before following the steps below, make sure that Normal is checked on the View menu and that Field
Codes is NOT checked.

    1.From the File menu, choose New, and choose the OK button to open a document based on the 
Normal template.

    2.From the View menu, choose Header/Footer, select Header, and choose the OK button.

    3.From the Insert menu, choose Object, select Word Document, and choose the OK button. The 
following phrase appears on the title bar:

Object in Document1

    4.From the View menu, choose Header/Footer, select Header, and choose the OK button.

    5.From the Insert menu, choose Object, select Word Document, and choose the OK button. The 
following phrase appears on the title bar:

Object in Object in Document1

    6.From the Window menu, choose Document1. From the File menu, choose Close.

    7.Choose Yes when prompted to save changes to Document1, and choose Yes again when 
prompted to update the embedded objects in Document1 before saving it. Name the document 
"Test_UAE," and choose the OK button.

    8.Open Test_UAE. From the View menu, choose Header/Footer, select Header, and choose the OK
button.

    9.A Word for Windows icon appears in the header to represent the MS Word object. Double-click 
the MS Word icon to edit the "Object in Test_UAE."

10. From the View menu, choose Header/Footer, select Header, and choose the OK button. 

Notice that no MS Word icon appears in this header; the object was not saved.

11. From the Insert menu, choose Object to embed the object again. Select Word Document, and 
choose the OK button.

12. From the Window menu, choose Test_UAE. From the File menu, choose Close. 

Choosing Yes to save changes and update the embedded objects results in either an 
unrecoverable application error or a recoverable application error.

Whenever either of these errors occurs, exit Windows completely, and reboot your system. If you



do not exit Windows completely and restart the machine, the computer's memory remains 
unstable, and further errors may occur.

Microsoft has confirmed this to be a problem in Word for Windows. We are researching this problem 
and will provide new information as it becomes available.

Additional Search Words

uae rae gp fault general protection



About This Guide

Tip: For the best readability, view the Word for Windows Setup & 
Troubleshooting Guide ViewNote in a maximized window by 
choosing Maximize from the Control menu (--).

This ViewNote contains articles from the Microsoft Knowledge Base that provide answers to common
Word for Windows Setup questions. The information in this ViewNote applies to Word versions 2.0, 
2.0a, 2.0a-CD, and 2.0b except where noted.

You move around in this ViewNote by choosing a "hotspot." Hotspots can come in the form of 
hypertext or graphic icons. Choosing a hotspot can bring up a pop-up window or a jump. 

The illustration below explains how to use the button bar located near the top of the ViewNote 
window. Choose a button to see an explanation of how to use it.

See also
Changing the Color of Your Hypertext
Trademarks



Trademarks

Note: The products below are manufactured by vendors independent of Microsoft; we make no 
warranty, implied or otherwise, regarding these products' performance or reliability.

3+, 3Com, and 3+Share are registered trademarks and 3+Open is a trademark of 3Com 
Corporation.
Adobe, Adobe Type Manager, and PostScript are registered trademarks of Adobe Systems, Inc.
TrueType is a registered trademark of Apple Computer, Inc.
VINES is a registered trademark and Banyan is a trademark of Banyan Systems, Inc.
ArcNet is a registered trademark of Datapoint Corporation.
DEC, Pathworks, VAX, and VMS are registered trademarks and DECnet is a trademark of Digital 
Equipment Corporation.
Fontware is a trademark of Bitstream, Inc. The Fontware mark is licensed to Bitstream, Inc. in the 
UK, France, and West Germany by Electronic Print Systems LTD.
Epson is a registered trademark of Epson America, Inc.
TCS is a registered trademark of Eurotherm International P.L.C.
DeskJet, Hewlett-Packard, HP, LaserJet, PCL, and Vectra are registered trademarks of Hewlett-
Packard Company.
IBM and OS/2 are registered trademarks of International Business Machines Corporation.
Lotus and Lotus Notes are registered trademarks of Lotus Development Corporation. 
Arial is a registered trademark of The Monotype Corporation PLC
NetWare and Novell are registered trademarks of Novell, Inc.
Qualitas is a registered trademark and 386-Max is a trademark of Qualitas, Inc.
Qemm is a trademark of Quarterdeck Office Systems. 
Sun and TOPS are registered trademarks of Sun Microsystems, Incorporated. 



Hotspot

Hotspots are text, graphics, or parts of graphics that provide links to other topics or information about 
the current topic. The mouse pointer changes to the shape of a hand when it is over a graphical or 
hypertext hotspot. 

To highlight all the hotspots in a topic, press CTRL+TAB.



Index Button

To find a topic from the index, choose the Index button and type a word or select one from the list. 
Index topics explain how to use this ViewNote. 

To find topics about Word for Windows, choose the Search button to search the entire document for 
specific words related to your query.

See also
Search Button



Browse Buttons

To move backward and forward to view the various topics available on the Contents screen, choose 
the << and >> Browse buttons .



Contents Button

To return to the Contents screen (the first screen), choose the Contents button .



Back Button

To return to the last screen you were viewing, choose the Back button.



History Button

To obtain a list of topics you have read, choose the History button. You can then choose a topic from 
the History list to return to that topic.



Search Button

To search the entire document for specific words, choose the Search button and type the desired 
word in the Search For text box.

For example, if you want to read all the topics in this ViewNote that refer to Windows, search on the 
word "Windows" by choosing the Search button and typing windows in the Search For text box. A list
of topics will appear. To view the desired topic, choose the Go To button.



Hypertext

Hypertext is text that, when chosen, brings up a new screen or pop-up window to provide additional 
information about the current topic or a related topic. Hypertext is often (but not always) colored and 
underlined.

To show all hypertext in a topic, press CTRL+TAB.

You can change the color of the hypertext on your screen.



Graphic Icons

Not all graphic icons are hotspots. In this ViewNote, the folder icons and 
the More Information button icons are graphical hotspots. You can 
choose them to see more information about a topic or to go to a related 
topic.
To show all the hotspots in a topic, press CTRL+TAB.

(The buttons you see here are just illustrations. You cannot choose them.)



Choosing a Graphic or Hypertext Link

You choose a graphic or hypertext link by either clicking it with a mouse or pressing TAB to highlight 
it, and then pressing ENTER.



Changing the Color of Your Hypertext

You can change the color of the hypertext in this ViewNote by placing a JUMPCOLOR setting in the 
[Multimedia Viewer] section of your WIN.INI file. (The WIN.INI file is located in the WINDOWS\
SYSTEM directory, and can be edited with any text editor, such as Notepad.)
The JUMPCOLOR setting syntax is

jumpcolor=<red-value> <green-value> <blue-value>

where the value is a number from 000 to 999, with 999 giving the highest intensity. You must include 
three digits for each value, and you must include each color value. For example, the following 
JUMPCOLOR setting changes your hypertext to a high-intensity blue:

jumpcolor=000 000 999

Blue text works well on non-white backgrounds. You can experiment with this setting to create a color
that works best for you.

Tip: Choose the Back button from the button bar to return to the previous screen.



Pop-up Windows

A pop-up window provides more information about a topic and keeps the original topic screen visible 
in the background. To return to the original screen, you can click anywhere with the mouse or press 
any key.



Jumps

A jump takes you to a related topic on a new screen. From there, you can navigate as you would in 
any screen. For example, choose the Back button to return to the previous screen.



THE INFORMATION PROVIDED IN THIS VIEWNOTE AND ANY SOFTWARE THAT MAY 
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